I burned the ubuntu-14.04.1-desktop-amd64.iso to a DVD-R after checking the iso with MD5SUM. From there, I rebooted, entered BIOS to make sure I was booting from the CD-ROM, and entered the Ubuntu install screen. I then selected the Install option, continue, continue, continue, finish, and then I was prompted to remove the DVD and press Enter.

At this point, when I press Enter, the computer boots to Windows after informing me that "Windows did not shut down properly." After that, when I reboot, I am given no option to boot from Ubuntu or from Windows 7 -- instead it boots straight to Windows.

Here's what I'm running..

Operating System: Windows 7 Home Premium 64-bit

System Model: HP Pavilion dv7 Notebook PC

Processor: AMD A6-3400M APU with Radeon(tm) HD Graphics (4 CPUs), ~1.4GHz


4 Answers 4


This usually happens when the bootloader for ubuntu is not installed in the Master Boot Record for the harddrive but instead it gets installed into a partition.

My advise is to put the live CD, open a terminal and install grub in the Master Boot Record for your hardrive.

sudo grub-install /dev/sdX

Where X is the letter of your harddrive, probably a.

Take a look at this related question (answer): https://askubuntu.com/a/271367/117382


Did you install on two harddrive or one?

If you did on two harddrive make sure that your booting to the right one.

If you installed on one, some motherboards recognise multiple partitions as different harddrives(mine did) make sure you selected the right one.

My first answer ever on askubuntu.com, hope I did it right

  • I installed it (or tried to) on just one harddrive. Unfortunately, when I enter BIOS there appears to be only one harddrive from which to boot.
    – Jay Kelner
    Feb 4, 2015 at 0:39
  • Hmm. Tried l reinstalling Ubuntu? Remember to take out all flash drives
    – Kim André
    Feb 4, 2015 at 13:34

I ended up just replacing Windows 7 with Ubuntu and deleting all of my files as a result. This was very risky but it worked.

  • You probably had Windows 7 hibernate function enabled. This is incompatible with Ubuntu boot...
    – Fabby
    Feb 9, 2015 at 6:44

I had a similar problem and, after a while searching, found a couple of sites which advocated shrinking the partition in Windows before installing Obuntu. In windows, I deleted the ubuntu partition then recreated it and went from there, Now have a perfectly working dual boot!

This link takes you through the steps, there are a few others around in a similar vein.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .