1

I recently installed Ubuntu 14.04 on my Sony Vaio SVP1322X2EB.

It's working great only I noticed that the touchscreen (which is enabled by default) affects my battery life. I don't use it, so now I usually turn it off after startup by using the following command:

`xinput disable 9`   

(9 is the number assigned to my touchscreen)

This, however, doesn't mean the touchscreen is disabled by default; I have to repeat this action each time I start up my computer.

To disable the drivers I have tried the following, from a different thread:

1.Edit /usr/share/X11/xorg.conf.d/10-evdev.conf

2.Add Option "Ignore" "on" to the end of touchscreen section

3.Reboot

Running the first command gives me the notification bash /usr/share/X11/xorg.conf.d/10-evdev.conf: permission denied.

so that doesn't work, and neither do the other suggestions made by other users, unfortunately (found here Disabling touch screen only temporarily and here: http://ubuntuforums.org/showthread.php?t=1600818)

Does anyone have any ideas on how to permanently disable the touchscreen?

  • For anyone else reading this, in order to determine what number my touchscreen has you first simply run the following command: xinput. You'll see a list of hardware devices on your computer plus the numbers assigned to them. – Smith Feb 4 '15 at 15:32
4

One option would be to have the xinput disable 9 command run automatically at every boot.

You can do this with the Startup Applications app installed by default in Ubuntu. Open the app and click the Add button to add a new Startup program.

  • Set the Name field as anything you like. (e.g. Disable Touchscreen)
  • Set the Command field as xinput disable 9.
  • The Comment field can be left blank.

Once you have this done simply click Add and it will take effect next time you reboot.

Note: This will only run once you have logged into the user account from which you created it. If there are other accounts that you need to disable the touchscreen for you can repeat this process for each user account or you can follow the instructions here to enable it for every user.

enter image description here

  • Hi, Sorry for the late response, this worked swimmingly. Thanks! – Smith Feb 13 '15 at 10:02
  • @Smith Good to hear! Fell free to accept my answer if you're satisfied with it. – Merri Feb 14 '15 at 19:46
  • @Merri: how safe is it to assume that "9" (or whichever id my touchscreen is assigned to) will always be the correct id? How is this id defined? – dsetton Jan 22 '16 at 11:40
  • @dsetton You can check by running xinput --list in the terminal to show all your devices and their id numbers. – Merri Jan 22 '16 at 11:50
  • @Merri: Hi, thanks for the reply! I did check the id number (and it's not 9), but my question is if this id will always be the same, even after reboots, distro upgrades, etc. I'm asking because I don't know how it was defined in the first place. – dsetton Jan 22 '16 at 11:54
4

For the people spewing out this suggestion to other touchscreen users please don't Edit /usr/share/X11/xorg.conf.d/10-evdev.conf --->"Ignore""on" Is WRONG! I've seen this on other posts as well.

If you want to put that command in you will blow up xserver! You won't get a screen at all, some systems will spit out an error during boot with a mismatch as well.

So follow the directions That Merri left, not the other suggestions. find out what your touchscreen is called via terminal

xinput list

and then adding the startup script. In Ubuntu you can type in startup applications in the dash. Then click on ADD and put your script in the "Command" section then click save, you can give it a title if you like so you know for next time what it does.

My screen is called ELAN Touchscreen So I would put in that in start up script

xinput -disable "ELAN Touchscreen"

This would be the easiest method, I don't know why people put stuff in these forums and don't even have a touchscreen of their own, or at least it sounds like they don't.

My xserver blew up every time I messed with that xorg file. I'm running a Dell Inspiron laptop 5547 model, Tried this on Ubuntu 15.10 and Linux Mint 17.

Changing your xorg file definitely will kill your system.

  • this should be higher up! I broke my xserver by adding ignore to the conf – Lawrence Benson Feb 19 '16 at 9:10
  • yeah i'm having limited success with that xorg filechange. will try your solution on next reboot (currently it's working but only because I hit "ubuntu" in startup options at just the right time) askubuntu.com/questions/968718/… – Oliv Utilo Oct 25 '17 at 15:14
1

Edit file the file with

sudo nano /usr/share/X11/xorg.conf.d/10-evdev.conf

Change MatchIsTouchscreen from "on" to "off" to look like this

Section "InputClass"
    Identifier "evdev touchscreen catchall"
    MatchIsTouchscreen "off"
    MatchDevicePath "/dev/input/event*"
    Driver "evdev"
    EndSection

Save, name and exit nano

Touchscreen is disabled and no longer detected in xinput list.

  • 1
    In all 3 posts that you have copy pasted this same answer, you've exactly same error: you've lost the leading slash in the path name, so the proper path is /usr/share/X11/xorg.conf.d/10-evdev.conf. – Sergiy Kolodyazhnyy Jun 15 '17 at 23:40
  • @Sergiy Kolodyazhnyy good catch, it was actually 4 posts, thank you for noticing. I just really want people to see the method i used because it is so effective. I struggled with my broken touchscreen for a lot of hours and if i had of come across this answer first it would have saved me a lot of headache. peace – Shawn Moore Jun 15 '17 at 23:49
  • 1
    Please don't do this. If you find such duplicate posts, just flag them as duplicates instead. – terdon Jun 16 '17 at 10:58
  • 1
    @terdon, copy that. Just a noob bud. cheers. – Shawn Moore Jun 16 '17 at 11:23
  • no worries, we've all been there :) – terdon Jun 16 '17 at 11:29
0

You need administrator privileges, in order to edit such files. Your first command should be sudo gedit /usr/share/X11/xorg.conf.d/10-evdev.conf and you will be prompted to enter the root password. Then carry on as you're suggested and you will be able to disable your touch screen.

Not the answer you're looking for? Browse other questions tagged or ask your own question.