0

I'm trying to pair a bluetooth keyboard to my Lenovo Ideapad Z70-50.

$ hcitool scan
Scanning ...

But nothing is found, even though my keyboard is in discovery mode. The device works, since I can pair it with my tablet. I'm trying to provide below details of my set up.

Any suggestions? Thank you!

$ uname -a
Linux zen 3.16.0-30-generic #40-Ubuntu SMP Mon Jan 12 22:06:37 UTC 2015 x86_64 x86_64 x86_64 GNU/Linux

$ lspci  | grep Net
02:00.0 Network controller: Realtek Semiconductor Co., Ltd. RTL8723BE PCIe Wireless Network Adapter

$ lsmod | grep bt
btcoexist              50429  1 rtl8723be
btusb                  32448  0 
bluetooth             446190  22 bnep,btusb,rfcomm

$ rfkill list
0: ideapad_wlan: Wireless LAN
        Soft blocked: yes
        Hard blocked: no
1: ideapad_bluetooth: Bluetooth
        Soft blocked: no
        Hard blocked: no
2: hci0: Bluetooth
        Soft blocked: no
        Hard blocked: no
3: phy0: Wireless LAN
        Soft blocked: yes
        Hard blocked: no
4: phy1: Wireless LAN
        Soft blocked: yes
        Hard blocked: no

$ sudo hciconfig 
hci0:   Type: BR/EDR  Bus: USB
      BD Address: 00:71:CC:1B:13:3C  ACL MTU: 820:8  SCO MTU: 255:16
      UP RUNNING PSCAN ISCAN 
      RX bytes:1363 acl:0 sco:0 events:99 errors:0
      TX bytes:1286 acl:0 sco:0 commands:92 errors:0

$ dmesg | grep -i blue
[    3.012078] usb 2-7: Product: Bluetooth Radio 
[   26.753961] Bluetooth: Core ver 2.19
[   26.753985] Bluetooth: HCI device and connection manager initialized
[   26.753991] Bluetooth: HCI socket layer initialized
[   26.753992] Bluetooth: L2CAP socket layer initialized
[   26.753999] Bluetooth: SCO socket layer initialized
[   27.540874] Bluetooth: BNEP (Ethernet Emulation) ver 1.3
[   27.540878] Bluetooth: BNEP filters: protocol multicast
[   27.540889] Bluetooth: BNEP socket layer initialized
[   27.761547] Bluetooth: RFCOMM TTY layer initialized
[   27.761558] Bluetooth: RFCOMM socket layer initialized
[   27.761563] Bluetooth: RFCOMM ver 1.11

$ lsusb 
Bus 001 Device 002: ID 8087:8000 Intel Corp. 
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 003 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 002 Device 005: ID 0bda:b728 Realtek Semiconductor Corp. 
Bus 002 Device 004: ID 5986:055e Acer, Inc 
Bus 002 Device 003: ID 0bda:0129 Realtek Semiconductor Corp. RTS5129 Card Reader  Controller
Bus 002 Device 009: ID 0b95:772a ASIX Electronics Corp. AX88772A Fast Ethernet
Bus 002 Device 008: ID 045e:0745 Microsoft Corp. Nano Transceiver v1.0 for Bluetooth
Bus 002 Device 007: ID 05e3:0610 Genesys Logic, Inc. 4-port hub
Bus 002 Device 006: ID 2001:3c15 D-Link Corp. DWA-140 RangeBooster N Adapter(rev.B3) [Ralink RT5372]
Bus 002 Device 002: ID 0424:2514 Standard Microsystems Corp. USB 2.0 Hub
Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
  • What is the result of lsusb – Jeremy31 Feb 3 '15 at 0:13
  • added at the bottom. BTW I'm running Ubuntu 14.10 – stivlo Feb 3 '15 at 0:29
1

The issue is the realtek device that is part of the wifi, see Bus 002 Device 005: ID 0bda:b728 Realtek Semiconductor Corp. This device doesn't work but causes issues with other USB bluetooth dongles when you try to use them. Later today I can build you a btusb.ko module that will ignore the Realtek as I did Disable internal RTL8723 bluetooth

But make it for your kernel as the one I posted there will only work for 3.13.0-44 There is a small chance that this will work for you after a reboot

echo "install btusb /sbin/modprobe --ignore-install btusb && echo '0bda b728' > /sys/bus/usb/drivers/btusb/remove_id" | sudo tee /etc/modprobe.d/bcmbtusb.conf
| improve this answer | |
  • Thank you Jeremy, I will try this when I get home tonight (it's on my home laptop) – stivlo Feb 3 '15 at 12:05
  • might be easier than that if you don't use the Realtek card for wifi. See if the internal wifi can be disabled in BIOS – Jeremy31 Feb 3 '15 at 12:15
  • I've disabled the card in bios and followed instructions in the linked post. now hcitool scan says "no such device". rfkill list shows ideapad_bluetooth and not the hci0 entry any more. I guess probably that's OK if the device or the driver is buggy. I suppose I should try to buy a bluetooth dongle then. – stivlo Feb 4 '15 at 0:02
  • Your wifi card can work with the instructions from askubuntu.com/questions/580551/… from my answer starting with the wget command. Is the 045e:0745 Microsoft Corp. Nano Transceiver v1.0 for Bluetooth not a true bluetooth device? – Jeremy31 Feb 4 '15 at 0:35
  • That's for the main mouse/keyboard. I'm not sure if it can also used for other bluetooth devices. I've tried instructions, however I get some warnings and after an error *** Can't find default configuration "defconfigs/rtfwifi"! Makefile.real:41: recipe for target 'defconfig-rtfwifi' failed make[1]: *** [defconfig-rtfwifi] Error 1 Makefile:40: recipe for target 'defconfig-rtfwifi' failed make: *** [defconfig-rtfwifi] Error 2 – stivlo Feb 4 '15 at 11:46

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.