I've bought the HP LaserJet Pro P1102w.

I want to use it with Ubuntu Lucid (10.04), but it is not in the list of supported printers. How can I install this printer on Lucid?


Your particular printer is supported via the hplip library. Unfortunately, the version by default in lucid is too old for your printer - lucid has version 3.10.2 and you require at a minimum v3.10.4

There is a "untrusted" PPA on launchpad with the latest version which you can install - this is from the hplip development team.

If you install this PPA, it will upgrade your lucid hplip library. Next time you plug in your printer it should then be recognised correctly.

The PPA's name is: ppa:hplip-isv/ppa, you need to add it to your software sources, which you can do by following these instructions:

Or via the command line:

sudo apt-add-repository ppa:hplip-isv/ppa
sudo apt-get update
sudo apt-get hplip

Related Questions:

| improve this answer | |

Thanks for your answers. I had problems with the HP LaserJet P1102w and Ubuntu Lucid (10.04), but I solved it. I use the USB-connection, so I haven't tried it with the WiFi yet.

The P1102w uses the driver foo2zjs, but I needed a version newer than 2010-05-28. The version in Lucid (10.04) is too old, but the one in Maverick (10.10) works fine. Luckily it's possible to install the package from Maverick in Lucid without dependency problems.

Instructions for everyone who needs it:

  • Go to http://packages.ubuntu.com/maverick/foo2zjs

  • Download the right package. Don't know if you need amd64 or i386? Type in a terminal: dpkg --print-architecture

  • Install gdebi if you don't have it already: sudo aptitude install gdebi

  • Install the printer driver: gdebi foo2zjs_*.deb

If you already have an older version of foo2zjs, you can replace the last two steps with (I didn't test this): dpkg -i foo2zjs_*.deb

| improve this answer | |
  • 3
    If this is this is the best answer you should accept it even it's your own. – N.N. Aug 23 '11 at 7:48

That printer works with hplip version 3.10.4+ (source). It works over USB, UTP and even the wireless works.

Lucid uses 3.10.2-2 according to package.ubuntu.com so you will need to install the newer version and that can be found on sourceforge.

| improve this answer | |

Apague la impresora. Sostenga la WLAN botones y RESET abajo y encender la impresora. Ubuntu se iniciará la instalación de la impresora. A continuación, la impresora debería funcionar.ME FUNCIONO DESPUES DE MESES DE INTENTARLO

Translation (with the help of Google translator):

Turn off the printer. Hold the WLAN and RESET buttons down and turn on the printer. Ubuntu will start installing the printer. Then, the printer should work. This worked after months of trying other things.

| improve this answer | |

Switch the printer off. Hold the buttons WLAN and RESET down and switch the printer on. Ubuntu will start the printer installation. Then the printer should work.

If that doesn't work, proceed as follows:

  • Get the driver from the HP-Home-Page by choosing (Linux-Ubuntu-10.04)
  • Copy the printer driver (e.g., hplip-3.11.7.run) from the download area to the desktop.
  • Open the terminal and enter at the prompt: cd desktop
  • At the next prompt enter: sh hplip-3.11.7.run
  • A longer routine begins with several questions to answer in between.
  • At the end try to print a test page. If you are not successful, switch the printer off and switch it on again by pressing WLAN- and RESET-Button at the same time.
  • Then the printer definitely works.

This worked for me on an HP CQ71 laptop with Ubuntu 10.04 LTS installed via Wubi in Windows 7 Professional SP1.

| improve this answer | |

For 12.10 I just had to run sudo hp-setup and then let it discover the printer and download the drivers.

| improve this answer | |
  • This does not answer the OPs question. The distibution being used here in 10.04LTS not 12.10. Is your answer valid for 10.04? – stephenmyall Nov 15 '12 at 16:18
  • @StephenMyall Even if it weren't valid for 10.04, how narrow do we want to construe this question? We don't want separate questions for setting up this printer in each release. – Eliah Kagan Jan 13 '13 at 8:29

It worked after I entered

root@dus:/var/log/cups# hp-plugin

It started to install some drives, failed, but reported that Plugin installation successful.

I'm on Ununtu 12.04.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.