3

I've tried several solutions, all of which do not work:

  • Using dconf to add 'wicd' and 'wicd-client.py' to the whitelist in com > canonical > unity-gtk-module (14.04 does not have unity > desktop > panel).
  • Adding it in "Startup Applications" (in fact, it was already there when I checked)
  • In hopes of getting unity > desktop > panel to appear in dconf-editor, I've tried:

    sudo add-apt-repository ppa:timekiller/unity-systrayfix 
    sudo apt-get update
    sudo apt-get upgrade
    

None of these have worked (I've restarted my computer after all of them).

Does anyone have any suggestions?

2
+50

For Ubuntu 14.04:

sudo add-apt-repository ppa:gurqn/systray-trusty
sudo apt-get update
sudo apt-get upgrade

For Ubuntu 14.10:

sudo add-apt-repository ppa:gurqn/systray-utopic
sudo apt-get update
sudo apt-get upgrade

Then, restart Unity by pressing Alt+F2 and typing unity or by logging out and back in. The PPA now automatically whitelists all applications so there's no need to manually whitelist individual apps to be able to use the systray.

If you want to revert the changes and go back to the default Unity packages from the Ubuntu repositories, use the commands below to purge the Unity systray whitelist PPA:

For Ubuntu 14.04:

sudo apt-get install ppa-purge
sudo ppa-purge ppa:gurqn/systray-trusty

For Ubuntu 14.10:

sudo apt-get install ppa-purge
sudo ppa-purge ppa:gurqn/systray-utopic

Then, restart Unity or log out and log back in.

Source

|improve this answer|||||
  • 1
    Hello. Did not work for me on Ubuntu 14.04. Any other options I can try? – Babbzzz May 15 '15 at 7:30
  • @Babbzzz: Welcome to Ask Ubuntu! ;-) We're very sorry, but this is not a good place to put another question as the only person seeing your comment will be me and I've got 14.04 and it works for me! ;-) So please first look over the existing answers and if none of them work, ask a new question and refer back to this question and explain what went wrong. ;-) – Fabby May 15 '15 at 20:28
  • This solution has done absolutely nothing for me... I'm also running 14.04 – Abraham Murciano Benzadon May 11 '17 at 15:34

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.