3

I need your help! I have the following version of JRE installed on my system:

java version "1.7.0_75" OpenJDK Runtime Environment (IcedTea 2.5.4) (7u75-2.5.4-1~trusty1) 
OpenJDK 64-Bit Server VM (build 24.75-b04, mixed mode)

Here are my alternatives:

There are 2 choices for the alternative Java (providing /usr/bin/java).

  Selection    Path                                            Priority   Status

* 0            /usr/lib/jvm/java-7-openjdk-amd64/jre/bin/java   1071      auto mode
* 1            /usr/lib/jvm/java-6-openjdk-amd64/jre/bin/java   1061      manual mode
* 2            /usr/lib/jvm/java-7-openjdk-amd64/jre/bin/java   1071      manual mode

When I run the following command to install the GUI:

java -jar PlatinGUI740_0-20012037.JAR

This is the output:

Exception in thread "main" java.lang.UnsupportedClassVersionError: com/sap/platin/micro/Microkernel : 
Unsupported major.minor version 52.0    
at java.lang.ClassLoader.defineClass1(Native Method)
at java.lang.ClassLoader.defineClass(ClassLoader.java:800)
at java.security.SecureClassLoader.defineClass(SecureClassLoader.java:142)
at java.net.URLClassLoader.defineClass(URLClassLoader.java:449)\
at java.net.URLClassLoader.access$100(URLClassLoader.java:71)
at java.net.URLClassLoader$1.run(URLClassLoader.java:361)
at java.net.URLClassLoader$1.run(URLClassLoader.java:355)
at java.security.AccessController.doPrivileged(Native Method)
at java.net.URLClassLoader.findClass(URLClassLoader.java:354)
at java.lang.ClassLoader.loadClass(ClassLoader.java:425)
at sun.misc.Launcher$AppClassLoader.loadClass(Launcher.java:308)
at java.lang.ClassLoader.loadClass(ClassLoader.java:358)
at sun.launcher.LauncherHelper.checkAndLoadMain(LauncherHelper.java:482)

But it says here that the GUI works with Java 7. What am I missing?

Update:

After @chronos00 shed some light on this matter, I tried his solution. However, I was not able to install JDK via sudo apt-get install openjdk-8-jre but was able via this link. The installer now shows the GUI but I still cannot proceed with install. Installer now gives me this error:

Installation of SAP GUI for Java 7.40 Installation has not finished succesfully. Installation has failed.

The installation of the SAP GUI for Java has failed with fatal errors.
Please check the installation log file: "/root/sapgui.log"

Installation details.
Copy Resources
Installed resource : GuiStartS.jar
Installed resource : JNetBeanS.jar
Skipped native optional resource : Linux-gmux.jar
Skipped native optional resource : Linux-graphics.jar
Exception details.


Internal exception: java.lang.NullPointerException
java.lang.NullPointerException at:
com.sap.platin.micro.installer.InstallationController.loadResource(InstallationController.java:1133)at:
com.sap.platin.micro.installer.InstallationController.downloadResources(InstallationController.java:1001)at:
com.sap.platin.micro.installer.InstallationController.addInstallationImpl(InstallationController.java:280)at:
com.sap.platin.micro.installer.InstallationController.addInstallation(InstallationController.java:132)at:
com.sap.platin.micro.Microkernel.install(Microkernel.java:274)at:
com.sap.platin.micro.Microkernel.main(Microkernel.java:798)
2
  • What is the command you used to get the first and second output?
    – chronos00
    Feb 9, 2015 at 1:33
  • 1
    first command was: java -version and the second: update-alternatives --config java
    – erik
    Feb 11, 2015 at 2:03

4 Answers 4

1

On Linux Mint 18 of the Ubuntu family with openjdk version "1.8.0_91" installed, I installed SAP GUI for Java 7.40 rev 7. I ran into the same error when I tried to start the SAP gui. I simply looked for javafx in the software center and installed Javafx/openjfx 8 - rich client application platform for java. Now it runs like a charm.

1

I have found similar error in Ubuntu 20.04. I have fixed with these commands:

sudo apt install -y openjfx
sudo cp /usr/share/openjfx/lib/javafx.properties /usr/lib/jvm/java-11-openjdk-amd64/lib/javafx.properties
0

I see the same behavior as you do with OpenJDK-7.

I solved it by installing version 8 of OpenJDK (sudo apt-get install openjdk-8-jre), and then selecting it using update-alternatives --config java

In my case, the output of update-alternatives --config java now looks like the following:

There are 2 choices for the alternative java (providing /usr/bin/java).

  Selection    Path                                            Priority   Status
------------------------------------------------------------
  0            /usr/lib/jvm/java-7-openjdk-amd64/jre/bin/java   1071      auto mode
  1            /usr/lib/jvm/java-7-openjdk-amd64/jre/bin/java   1071      manual mode
* 2            /usr/lib/jvm/java-8-openjdk-amd64/jre/bin/java   1069      manual mode

Installation and execution followed properly after that.

Hope this helps!

PS: Please note that I am using the following version of SAP-PlatinGUI PlatinGUI740_0-20012039.JAR. I don't know if there is any difference with the one you were trying, but I also had the same problem with OpenJDK7.

4
  • Thanks @chronos00. However, I cannot install java via the command sudo apt-get install openjdk-8-jre. Do you have repos that have to be added to my sources? Anyway, I tried using this link to install the JDK. The installation GUI loaded but I still ended up in an error: Internal exception: java.lang.NullPointerException java.lang.NullPointerException `
    – erik
    Mar 1, 2015 at 9:53
  • I am running Ubuntu 14.10 and OpenJDK 8 vas already in the repos. It seems that this is not the case with Ubuntu 14.04. You can read more about it here.
    – chronos00
    Mar 1, 2015 at 22:23
  • On another comment, I must unfortunately add to this that even though the installer completed successfully with OpenJDK 8, and I was able to launch SAP GUI, the connection broke after I successfully logged in. I had to revert to SAP GUI 7.3 rev3 with OpenJDK7. The link in my previous comment had instructions to install Oracle's Java in Ubuntu 14.04. You might as well try that too.
    – chronos00
    Mar 1, 2015 at 22:27
  • Also did the same thing. Used GUI 7.3 rev3 instead. Works fine with JDK8 so I just left Java as is. Anyway, this would do for now. Unless some unfortunate bloke goes through the same thing then they may wake this ticket up! LOL Thank you @chronos00!
    – erik
    Mar 3, 2015 at 4:43
0

Please go to http://www.webupd8.org/2012/09/install-oracle-java-8-in-ubuntu-via-ppa.html

or hit Ctrl-Alt-T to open up a Terminal. then.. put this line in and hit enter

sudo add-apt-repository ppa:webupd8team/java

then put this line in and hit enter

sudo apt-get update

then put this line in and hit enter

sudo apt-get install oracle-java8-installer

now with java 8 installed, close the Terminal.

Right click on the PlatinGUI740_2-20012039.JAR icon on your desktop(or wherever) and select "Open with Oracle Java8 Runtime"

and that's it!! you're good to go.

0

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.