1

I just installed Ubuntu 14.10 on this new laptop and am having issues with the touchpad.

The touchpad is one of those all-in-one style ones where there are no separate left/right buttons. Because of this, if I hold one finger in the area where I am supposed to click, and navigate with another, it just goes no where. Now, multitouch does work for things such as scrolling or two-finger tapping for a right click.

1

Following this article solved my problems

sudo apt-get install xserver-xorg-input-mtrack

then edit the xorg.conf file

sudo -H gedit /etc/X11/xorg.conf

and add:

Section "InputClass"
    MatchIsTouchpad "on"
    Identifier      "Touchpads"
    Driver          "mtrack"
    Option          "Sensitivity" "0.55"
    Option      "FingerHigh" "12"
    Option      "FingerLow" "1"
    Option          "IgnoreThumb" "true"
    Option          "IgnorePalm" "true"
    Option          "TapButton1" "0"
    Option          "TapButton2" "0"
    Option          "TapButton3" "0"
    Option          "TapButton4" "0"
    Option          "ClickFinger1" "1"
    Option          "ClickFinger2" "3"
    Option          "ClickFinger3" "3"
    Option          "ButtonMoveEmulate" "false"
    Option      "ButtonIntegrated" "true"
    Option          "ClickTime" "25"
    Option          "BottomEdge" "25"
    Option      "SwipeLeftButton" "8"
    Option      "SwipeRightButton" "9"
    Option      "SwipeUpButton" "0"
    Option      "SwipeDownButton" "0"
    Option      "ScrollDistance" "75"
EndSection

The article also says,

You may have existing configurations for the synaptics touchpad driver. Comment out existing stuff by adding a # to the beginning of each line. Then add the configuration block from above

Save, exit, and reboot or restart lightdm display manager.

0

Your touchpad (most likely) is working correctly.

The solution would be to only have one finger on the touchpad, if you want to move around.

If you hold one finger on the touchpad and are moving a second finger around, your touchpad may either recognize a multi-touch gesture or just ignore the second finger due to the first finger staying still. In both cases it will not translate as mouse movement.


I would suggest to enable "tap to click", so that you do not actually need to use the physical button(s). (There is actually at least one physical button, but instead of being separate the whole touchpad is the button)

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.