9

This is the scenario I have right now, since it is my first time having some headphones and also a speaker system connected to the PC.

I have two apps opened: Steam & Music Player (eg: Banshee, Rhythmbox)

I want the music player to output it's sound to the Speaker system and I want Steam to output it's sound to my headphones. This way, everybody around can hear the music while I take a couple of hours playing L4D2.

How can I do this since the only thing I see is the following:

enter image description here

NOTE - First time playing around with Steam, sound system and music player like this. Like I said, never had a headphone, even less a stereo system connected to it.

3
  • Have you tried JACK?
    – user216043
    Feb 2, 2015 at 8:27
  • @JJoao What do you mean? Feb 2, 2015 at 23:58
  • 1
    JACK is designed as a "audio connection kit" sound server and it is powerful when you need complex connections (ex connect output to the headphones, and to the input of a recorder application). (see also qjackctl)
    – user216043
    Feb 3, 2015 at 9:05

1 Answer 1

15

Well found the answer after searching about pulseaudio,alsamixer and a whole bunch of other stuff. This will only work if you are using the speakers and headphones on different audio devices (Like the speakers connected to the Motherboard sound system and the headphones are connected via USB). Basically this is the road I took:

  1. Install the PulseAudio Volume Control

    sudo apt-get install pavucontrol
    
  2. Open Dash and type "pulseaudio" and then open the PulseAudio Volume Control

    enter image description here

  3. On the Playback Tab and you should see all the current applications using the sound system (If not then at the bottom of that Tab, there is the option to show all applications). Select the application you wish to change and select which output device to use for that specific application.

    enter image description here

With this setup, the sound from my music player goes out to the speaker system and the sound from Steam goes to my USB headphones. This would actually be a nice option to have directly in the sound system.

In my case I have:

  • One USB Headphone (Connection is via USB so it counts as 1 external output sound device)
  • Inboard sound system on motherboard (Everything connected to it counts as the same external sound device, so if a headphone is connected to it, this answer will not work since it will be seen as part of the inboard sound system and not a completely separate external output).
  • HDMI connection (HDMI connections offer Video, Audio and Networking all in one, so it counts as another output sound device).

This is why this answer would work for me, but not for anybody that connects all devices to the same sound device as mentioned in the comment by Takkat's research.

5
  • 2
    This will only work when the headphones are attached to a different sound card or if the card you have supports two output streams (they usually don't). In most cases we just have a single card which switches it's profile on plugging in the headphones. Another stream can then not be sent to another output.
    – Takkat
    Feb 1, 2015 at 21:46
  • @Takkat Many thanks, in my case, I happened to have a USB headphone (Basically not connected to the internal audio system). Will update the answer. Feb 2, 2015 at 3:41
  • @LuisAlvarado, have you found any command line way of doing that?
    – user216043
    Feb 2, 2015 at 8:23
  • @JJoao Not yet but it is a nice way of automating the whole thing. Feb 2, 2015 at 23:58
  • 1
    @LuisAlvarado, I saw that pacmd makes it possible to configure many things about pulse audio connections; Ex pacmd set-default-source .... Still I could not control many necessary details.
    – user216043
    Feb 3, 2015 at 9:09

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.