The internet cuts off at random times. Sometimes I start Ubuntu and it's instantly off, other times it's when I open or close a program. Sometimes I can operate for days at a time, before it stops working.

I have a rlt8192se.

I know very little about Ubuntu and Linux in general. I have tried a couple of solutions with no luck. Because of the wireless issue, instead of really switching to Ubuntu, I'm just playing with it and mostly using Windows 7. I would categorize myself as a novice and I need your help to solve this problem.


  • I'd like to add that it can't be turned off and turned back on, I have to reboot back into Ubuntu in order to get it working again. – Humblebuntu Feb 1 '15 at 21:08
  • Actually, I could be wrong about it being the rtl8192se because in other places I see rtl8191sevB, in fact, it's more likely that it's the 8191sevB. Maybe Ubuntu is using the wrong driver by default? I ran sudo lshw -c network and it showed me 8191, I think that's a hardware identifier. – Humblebuntu Feb 2 '15 at 4:48
  • I've also found this post forums.opensuse.org/showthread.php/… There they used compat-wireless to get an older driver to work. That program has been renamed to backports and can be found here: drvbp1.linux-foundation.org/~mcgrof/rel-html/backports But I have little idea how to really get it running and solve my problem. – Humblebuntu Feb 2 '15 at 4:52
  • Now I need to know how to change the wireless driver in the kernel. There are several drivers listed here: linuxquestions.org/questions/linux-newbie-8/… ##### It's this one I believe Realtek RTL8192SE/RTL8191SE firmware, version 4.816.2011 (rtlwifi/rtl8192sefw.bin) – Humblebuntu Feb 2 '15 at 7:52
  • Back to the backports thing: Found the driver in a collection here: packages.debian.org/squeeze-backports/firmware-realtek – Humblebuntu Feb 2 '15 at 8:02

There is one and only one driver in Ubuntu that will claim and drive your device. You can't arbitrarily decide to change the driver from rtl8192se to, for example, rtl8192ce. You can compile and replace your rtl8192se with a newer version of rtl8192se. However, newer is not always better.

Find out what driver you currently use:

lsmod | grep rtl

Find out more about your device:

lspci -nn | grep 0280 

If, for example, the pci.id of your device is 10ec:8174, then you can see the alias here:

modinfo rtl8192se
alias:          pci:v000010ECd00008174sv*sd*bc*sc*i*

One and only one driver in Ubuntu has that alias and therefor drives your device.

There are probably some changes you can make at the router to help. WPA2-AES is preferred; not any WPA and WPA2 mixed mode and certainly not TKIP. Second, if your router is capable of N speeds, I have better luck with a channel width of 20 MHz in the 2.4 GHz band instead of automatic 20/40 MHz. I also have better luck with a fixed channel, either 1, 6 or 11, rather than automatic channel selection. Also, be certain the router is not set to use N speeds only; auto B, G and N is preferred. After making these changes, reboot the router.

There are also some things to adjust on your computer. I recommend that your regulatory domain be set explicitly. Check yours:

sudo iw reg get

If you get 00, that is a one-size-maybe-fits-all setting. Find yours here: http://en.wikipedia.org/wiki/ISO_3166-1_alpha-2 Then set it temporarily:

sudo iw reg set IS

Of course, substitute your country code if not Iceland. Set it permanently:

gksudo gedit /etc/default/crda

Use nano or kate or leafpad if you don't have the text editor gedit. Change the last line to read:


Proofread carefully, save and close the text editor.

Next, I'd set IPv6 to Ignore in Network Manager: http://docs.fedoraproject.org/en-US/Fedora/18/html/Installation_Guide/images/netconfig/network-connections-ipv6-ignore.png This example is for ethernet, but you want wireless.

If these changes are ineffective, there are some driver parameters we might try:

sudo -i
echo "options rtl8192se swenc=1 fwlps=0 swlps=1"  >  /etc/modprobe.d/rtl8192se.conf

Any improvement?

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.