14

I have tried to use the xrdp to remotely connect from Windows to Lubuntu. I have tried several ways and have followed several guides but nothing worked. When trying to connect from Windows I am asked for username and password. I enter them but the only thing that is displayed is some kind of gray screen and the cursor is just an cross. Nothing happens after that.

0

1 Answer 1

20

First open a terminal and enter sudo apt-get install xrdp. When that is installed enter sudo nano /etc/xrdp/startwm.sh in the terminal. Make sure the last line looks like this:

. /etc/X11/Xsession

Then go to your home folder, rightclick and select Show hidden. If there is no file named .xsession, create it. If there is a filed named like that, open it and make sure that it looks like this when your done: lxsession -e LXDE -s Lubuntu

Now type sudo service xrdp restart in the terminal to restart xrdp. Now it should work :)

3
  • 1
    I have to tell you that I always come back to this answer after re-setting up my server. I'm so glad that you wrote this!
    – codepleb
    May 19, 2018 at 8:55
  • 1
    My last line looks like this: exec /bin/sh /etc/X11/Xsession and it's working too .. just a bit different call. Jan 9, 2021 at 9:49
  • On my old A/Open Digital Engine (Intel 945GM Express Chipset) with Lubuntu 18.04 this works, but it breaks Xorg on the console. Jul 27, 2021 at 12:01

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .