I'm running Ubuntu 14.10 in VMware Player on Windows 7. I have installed open-vm-tools instead of VMware Tools because VMware's software was unable to compile the kernel module required for file sharing. I cannot get my shared folder to mount with sudo mount -t vmhgfs .host:/$(vmware-hgfsclient) /mnt/hgfs or sudo vmware-hgfsmounter .host:/$(vmware-hgfsclient) /mnt/hgfs. Both return Error: cannot canonicalize mount point: No such file or directory. I have no idea what this is referring to or how to fix it.

My way of solving this issue is to resort to vmhgfs-fuse installed with open-vm-tools.

Either mount locally using vmhgfs-fuse .host:/$(vmware-hgfsclient) ~/some_mountpoint or globally using sudo mount -t fuse.vmhgfs-fuse .host:/ /mnt/hgfs -o allow_other. To then make mounting globally persistent add the following line to your /etc/fstab:

.host:/ /mnt/hgfs fuse.vmhgfs-fuse allow_other 0 0

  • The only thing I would add to this solution is that you might consider other file system options, for example "allow_other,uid=1000,gid=1000,auto_unmount,defaults". I installed the guest OS by pointing VMware at the downloaded ISO image. I did not explicitly let VMware install tools for me, and initially updated the Ubuntu installation. At that point open-vm-tools was installed, I did not have to install the package manually, and vmware-config-tools.pl did not appear to be part of the installed package. – M.B Nov 28 '16 at 18:09
  • Confirmed this works for 16.04 as well. – Kenneth Apr 6 '17 at 7:34
  • 1
    Works on 17.04 too and definitely a better solution than hacking the open-vm-tools – fmo Jun 6 '17 at 15:42
  • 1
    Ubuntu 14.04 installed open-vm-tools , but there is no vmhgfs-fuse. – Mithril Jun 22 '17 at 13:57
  • works perfectly, thanks – Benny Dec 10 '17 at 13:21

As the other answers didn't work for me, I finally got it working after long time of digging from this link : Files missing in /mnt/hgfs on Ubuntu VM? where PieCot gives the solution:

$ git clone https://github.com/rasa/vmware-tools-patches.git
$ cd vmware-tools-patches
$ ./patched-open-vm-tools.sh
  • This answer works, although I'm not sure it's enabling shared with folders with open-vm-tools. It seems to be downloading tools directly from vmware and patching them. – Shawn Hoover Apr 14 '16 at 21:26
  • This was the only way I got it working (tried to build open-vm-tools from source but without a luck on Debian Jessie). One small notice make sure your user is in sudoers list otherwise you had to remove sudo call from scripts and run commands from patched-open-vm-tools.sh manually as I did – Geradlus_RU Nov 19 '16 at 23:09
  • Working here for Ubuntu Gnome 16.04 LTS. – FourtyTwo Jun 7 '17 at 6:44

Ubuntu 17.10 requires installing the vmhgfs driver through the proprietary VMWare Tools tar-based installation. For details see http://partnerweb.vmware.com/GOSIG/Ubuntu_17_10.html

On the VM make sure:

That you have folder sharing enabled

That you have at least one folder shared between the host and guest

On the Ubuntu guest:

Check /mnt/hgfs to see if you can access the folder, if your unable to do so run this tools command:

sudo vmware-config-tools.pl

Update the fstab using:

gksu gedit /etc/fstab

Use a text editor to enter the following at the end of the file:

.host:/{shared-folder} /{path-to-mount-on} vmhgfs defaults,ttl=5,uid=1000,gid=1000   0 0

The final step is to restart your vm ( you may need to restart it , or get an error saying unable to mount, just skip this and restart a few times)!

Thanks, hope this helps!

  • I refered to this while answering your problem: askubuntu.com/questions/29284/… – Trevor Clarke Feb 1 '15 at 1:49
  • 2
    I'm not using VMware Tools, so "vmware-config-tools.pl" does not exist on my installation. I'm not using it because it gave me trouble before. – Melab Feb 1 '15 at 18:38
  • For this I'm using open-vm-tools. I couldn't get the instructions to work with VMware's software. Do you have anything else? – Melab Mar 22 '15 at 19:51
  • "great" answer ... few "small" problems apt-file find vmware-config result nothing (vmware-config-tools.pl DON'T EXISTS ANYMORE in any Ubuntu package), also, for the rest of your "GREAT ANSWER", grep -i vm /proc/filesystems also return nothing, so, no support for vmhgfs in entire system at all ... YES I updated apt-file, YES I have open-vm-tools and open-vm-tools-desktop installed ... so, keep up the "good work" – THESorcerer Jun 6 '16 at 17:41

This worket for me in Debian, I thing that will be the same on Ubuntu.

Install open-vm-tools-dkms package.

apt-get install open-vm-tools-dkms

Create a mount point.

mkdir /mnt/hgfs

Mount all chares in the mount point. With permission to all users

/usr/bin/vmware-vmblock-fuse /mnt/hgfs -o allow_other

It simply means that your mount point does not exist.

$ ll /mnt
total 12
drwxr-xr-x  3 root root 4096 Feb 22 20:37 ./
drwxr-xr-x 22 root root 4096 Feb 22 20:16 ../
drwxr-xr-x  2 root root 4096 Jan  3 04:56 cdrom/

$ sudo mount -t vmhgfs .host:/Share /mnt/hgfs/Share
Error: cannot canonicalize mount point: No such file or directory

$ sudo mkdir -p /mnt/hgfs/Share

$ ll /mnt/hgfs
total 12
drwxr-xr-x 3 root root 4096 Feb 22 20:52 ./
drwxr-xr-x 4 root root 4096 Feb 22 20:52 ../
drwxr-xr-x 2 root root 4096 Feb 22 20:52 Share/

$ sudo mount -t vmhgfs .host:/Share /mnt/hgfs/Share

Your Answer

 

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.