43

I have LightDM installed and can start it with sudo start lightdm. But at boot, GDM is still the default. How can change this so LightDM is loaded automatically at boot instead of GDM?

0

3 Answers 3

46
sudo dpkg-reconfigure lightdm

Will prompt you to make it default. More information here:

3
  • 1
    I have the feeling it is not working $ sudo dpkg-reconfigure lightdm [sudo] password for user: dpkg-maintscript-helper: warning: environment variable DPKG_MAINTSCRIPT_NAME missing dpkg-maintscript-helper: warning: environment variable DPKG_MAINTSCRIPT_PACKAGE missing
    – seb
    Sep 3, 2011 at 23:43
  • @ seb, I get the same warning and my issue (askubuntu.com/questions/63134/…) has not been fixed... I'm quite certain I'm running LightDM because entering "lightdm --test-mode" in a console gives me the exact same login screen.
    – Matthijs
    Sep 30, 2011 at 8:59
  • I have the same problem. Googling reveals we are not alone, but there appears to be no solution.
    – user12753
    Nov 9, 2011 at 9:34
10

/etc/X11/default-display-manager should currently contain something else than lightdm.

Like I answered in another question, since LightDM starts on your machine, you should reference the binary in /etc/X11/default-display-manager :

sudo sh -c 'echo "/usr/sbin/lightdm" > /etc/X11/default-display-manager'
2

Do this:

$ sudo systemctl disable gdm.service  
$ sudo systemctl enable lightdm.service

Here enable starts service at boot. You can know more about it here.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .