1

This question already has an answer here:

Here is the error hope i can get some help, i show you the update manager and the line of the error, if you need something else just ask for it.

E: Malformed line 59 in source list /etc/apt/sources.list (dist parse)
E: The list of sources could not be read.

Error line:

deb http://archive.canonical.com/ partner

marked as duplicate by karel, Rinzwind, g_p, Aibara, Fabby Feb 1 '15 at 10:11

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

  • just comment it out using # and try apt-get update again. – j0h Jan 31 '15 at 18:36
2

The correct form of canonical partner repository address to be saved in /etc/apt/sources.list is following:

deb http://archive.canonical.com/ubuntu <codename> partner

Just change the codename according to the release of Ubuntu you are using. For example the codename for Ubuntu 12.04 is precise, so the correct form for Ubuntu 12.04 will be:

deb http://archive.canonical.com/ubuntu precise partner

The codename of 14.04 is trusty.

So replace the malformed line with the correct form.

  • but it doesnt allow me to save the chances – Stefan Popescu Jan 31 '15 at 18:23
  • @StefanPopescu: Is the problem solved? – heemayl Jan 31 '15 at 18:44

Not the answer you're looking for? Browse other questions tagged or ask your own question.