4

After a lot of trying and installing I don't know anything more to I can do to get this running.

I am having trouble installing the current Nvidia proprietary driver 346.35 on a Nvidia 840M graphics card, in combinations with an Intel i5-4210U cpu, kernel 3.13.0-45 on Ubuntu 14.04.1 64 bit

After installing the driver (manually from Nvidia driver page) and restarting lightdm / rebooting I get to the login screen and everything is looking normal. Once I login the screen resolution gets distorted and nothing more than "System program problem detected" is displayed, Unity / Compiz do not load.

I also tried installing the NVIDIA drivers from edgers ppa:xorg-edgers/ppa. After a reboot you hear the Ubuntu starting sound but the screens stays black.

The only thing you can do in both cases is ctrl+alt+ F1 and uninstall all nvidia drivers to get the Ubuntu desktop loading.

Solutions that did not work:

I've never had any trouble installing the proprietary Nvidia driver on linux before, maybe someone can help me here. The image below shows the bad screen resolution after login.

Bad screen resolution after login

  • Sorry this leads to the same black screen problem I have mentioned. So no duplication here. – Flatron Jan 31 '15 at 12:03
  • 1
    Okay now the strangest thing is that if I let the Laptop sit at the login screen (black screen) for around 30 minutes, suddenly the screen turns on and everything is working?! – Flatron Jan 31 '15 at 16:08
  • Voting to re-open... – Fabby Feb 2 '15 at 21:02
  • @Fabby so you are having a similar issue? – Flatron Feb 5 '15 at 9:04
  • No, I solved my issue a long time ago... (I also run a different NVidia then you) I just think your Q&A adds some new information to the site specifically for the 840M... ;-) – Fabby Feb 5 '15 at 9:15
2

Okay I have finally found a solution for the problem!

Thanks to these threads:

The solution is:

When the computer has booted up and you see the black screen press ctrl+alt+F1 and log in with your user account.

Edit your xorg.conf with sudo nano /etc/X11/xorg.conf

Find the line that says: Section "Screen"

Insert a new line that says UseDisplayDevice "DFP"

Save with ctrl+o+Enter and exit with ctrl+x


Next install bumblebee with sudo apt-get install bumblebee.

Then reboot sudo reboot

  • 1
    Thanks for your hint I didn't want to look arrogant, accepting my own answer ;) – Flatron Feb 2 '15 at 20:12
  • 2
    It's a good answer that will probably help someone who has a similar problem with the NVIDIA 840M driver. – karel Feb 2 '15 at 20:29

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.