1

I'm trying to develop Torque2D on a 32-bit chroot, as there's no 64-bit version as of yet, and it requires libopenal-dev, among other packages to compile properly. I've tried compiling it without it without success, and here's the problem I'm trying to surmount.

If I try

apt-get install libopenal-dev

It simply says

E: Unable to locate package libopenal-dev

if I'm in chroot, but installs fine outside. The other packages that torque2D required installed fine inside the chroot as well. Little help?

2
  • what is the output of cat /etc/apt/sources.list when you are in chroot or cat /chroot/etc/apt/sources.list from outside the chroot.
    – g_p
    Jan 31 '15 at 11:16
  • I'll give it a shot.
    – Fingerless
    Feb 2 '15 at 2:32
1

That's a simple fix. Just copy the contents of /etc/apt/sources.list from outside chroot, then log-in back to chroot and open up /etc/apt/sources.list (inside chroot) and paste the contents. You just need to do sudo apt-get update inside chroot and you're ready to apt-get install libopenal-dev.

0

Use this command to update your repositories.

sudo apt-get update
1
  • I tried that, I'll give it another shot.
    – Fingerless
    Feb 2 '15 at 2:31

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.