1

Just having my first play with 14.04 LTS (server), and I'm struggling!

The upgrade from 12.04 'almost' worked, but after struggling with intermittent hangs decided to back off and do a fresh install. There were numerous problems getting a bootable system, but finally achieved this with an absolutely clean install of a minimal system on totally fresh partitions.

My next step was to install lightdm/lightdm-gtk-greeter to give me a desktop manager. lightdm installed fine, but the greeter installation fails with

update-alternatives: error: alternative path /etc/lightdm/lightdm-gtk-greeter-ubuntu.conf doesn't exist'

Quite correct - it doesn't. I took a stab that this was purely a creation problem, so created an empty file, reran the installation, and it appears to work successfully. However, any attempts to start lightdm fail with

Seat: Stopping; failed to start a greeter

I haven't found anything in the greeter logs, and suspect the problem goes back to the greeter installation issues, and its not quite as simple as fudging the missing file. I've removed/reinstalled both lightdm and the greeter a number of times, but haven't got any further.

All versions should be the current stable versions - 1.10.3 for lightdm, and 1.8.5 for the greeter.

I've spent a bit more time today seeing if I could get to the bottom of this. I'm still suspicious that something hasn't installed correctly, but haven't a clue what.

I deinstalled the standard gtk greeter, and installed an alternative greeter (I happened to grab lightdm-webkit-greeter for no other reason that it was readily available). This installed fine, and on reboot I was presented with a standard login screen. That's a step forward, but it was impossible to login - it refused to authenticate.

Having a look at the lightdm log, there are some indications that authentication worked fine, but session creation was the culprit. There are log entries of the form;

  • Authenticate result for user andrew: Success
  • User andrew authorized
  • Greeter requests session ubuntu
  • Seat: Failed to find session configuration ubuntu
  • Seat: Can't find session 'ubuntu'

Not sure if this is relevant at all, but I've been trying to understand exactly what config files should be present. /etc/lightdm exists, but is empty (I understand this was deprecated in 14.04, so makes sense). In /usr/share/lightdm/lightdm.conf.d there are the following config files;

40-lightdm-webkit-greeter.conf
50-greeter-wraper.conf
50-guest-wraper.conf
50-unity-greeter.conf
50-xserver-coand.conf

I won't pretend I understand how all these fit together, nor exactly what I should expect, but I assume the leading numbers give some order for processing these. A couple of entries in this forum have referred to a 50-ubuntu.conf, but I don't have one of those. Should there be one there (ie. is this the 'ubuntu' mentioned in the session creation error)? If so, this could indicate the problem is with the lightdm installation rather than the greeter?

1

The easiest way to add a desktop to a server is to run this command:

sudo apt-get install ubuntu-desktop

OTOH, then you would be far from a "minimal system"...

  • That was all too easy! I never wanted a minimal system, but was having problems getting a bootable end result if I tweaked any of the server install options (boots were failing before I even had access to a keyboard or mouse which was making things a bit tricky) – Andrew McLaren Feb 1 '15 at 22:02
  • - didn't quite finish the above... It felt like there had to be an easier option than the direction I was going, and the "ubuntu-desktop" was it. Obviously installs a lot more than the piecemeal approach I was taking, and no doubt more consistent, as now have a desktop. Its still reporting one error that I'll need to look at, but a huge step forward. – Andrew McLaren Feb 1 '15 at 22:02
  • Maybe spoke too soon. Was doing an update to bring everything 100% up to date, system (or maybe just desktop) hung, and after reboot screen has dropped down do default granularity (ie. minimal pixels), updater now fails (maybe due to a partial update) and can no longer login to a terminal session (Buffer I/O error). But that's all gist for a new problem! I love Linux upgrades - at the moment I'm tempted to revert back to 12 LTS! – Andrew McLaren Feb 1 '15 at 22:25
  • @AndrewMcLaren: Sorry to hear that, and yeah, it's a new problem and maybe a new question here. Can't help wondering, though: If you want a desktop, why didn't you start with a desktop ISO in the first place? – Gunnar Hjalmarsson Feb 1 '15 at 22:30
  • Hi Gunnar - thanks for the commiserations! I run a number of server type things on the system, such as PostgreSQL and Apache, but it also runs as my Linux workstation. As to which direction its better to start from, hadn't really given it much thought, but had previously started with an LTS server and added what I needed from there. I'll have a play starting from a desktop ISO and see how we go. Andrew – Andrew McLaren Feb 2 '15 at 1:27
1

Just to close the loop, I think I've finally got to the bottom of this.

A desktop installation also had similar problems, but I was finally left with a clue that pointed to the graphics subsystem. This is running on a older ASUS motherboard with integrated graphics (Nvidia 7050 series). I took a stab and upgraded the Nvidia drivers to the latest compatible with that generation, and everything now appears stable.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.