I would like to use Compiz in Xubuntu (under xfce obviously).

I have seen this tutorial: http://www.ghacks.net/2010/07/11/run-compiz-with-xfce4/

Firstly, this didn't work well for me, because when trying compiz –replace ccp & in a terminal, it tells me there is no plugin such as cpp, and the window decorations are lost right away.

Is there a reliable way to run Compiz with XFCE, please? I miss my desktop cube.


Thanks for the answers so far. Just running compiz --replace still causes the complete loss of window decorations.

Also, I tried fossfreedom's suggestion, and then I get the output below. I installed emerald initially because it was complaining about not finding it, but I think I had the segfault even without emerald.

(some other output)
/usr/bin/emerald: Screen 0 on display ":0.0" already has a decoration manager; try using the --replace option to replace the current decoration manager.
Segmentation fault
Setting Update "command"


Well, turns out that just trying to run emerald by itself ends with a segfault, and apparently this is a known bug. Used the solution here to resolve that problem: http://www.webupd8.org/2011/05/get-emerald-to-work-in-ubuntu-1104.html

Still, I wasn't actually hoping to use Emerald, but what the heck.

  • I removed emerald, and now it just complains about not finding it (no segfault after all), but still no window decorations. – mydoghasworms Aug 20 '11 at 20:16
  • I've repeated your segfault with emerald - however I can remove it successfully, logout and login and rerun the compiz command successfully. Can you do unity-window-decorator --replace & - this should work if you have install compiz-gnome package (installed automatically with the packages in my answer) – fossfreedom Aug 20 '11 at 20:31
  • Well, I noticed that running emerald --replace by itself also ends with a segfault. Turns out it's a known bug. Will update my question quickly. – mydoghasworms Aug 21 '11 at 16:06
  • Can you add your update as an answer and mark this as answered? – RolandiXor Sep 3 '11 at 18:29
  • I most certainly can. – mydoghasworms Sep 4 '11 at 8:55

The following works for me:

sudo apt-get install compiz gnome-themes compizconfig-settings-manager
compiz --replace ccp &

If there are any errors displayed in the terminal, please add the output into your question.

  • Package gnome-themes is not available, but is referred to by another package. This may mean that the package is missing, has been obsoleted, or is only available from another source E: Package 'gnome-themes' has no installation candidate – Aaron Franke Jun 3 '16 at 0:01

Well, turns out that just trying to run emerald by itself ends with a segfault, and apparently this is a known bug.


sudo add-apt-repository ppa:malteworld/compiz
sudo apt-get update
sudo apt-get upgrade


  • Ha, that is so clever fossfreedom! I have always wondered about all the linked answers that will eventually become 404s. You have shewn me a better way! – mydoghasworms Sep 4 '11 at 9:01

ccp is a name of a plugin. If you don't have it installed, then you can't load it. Try compiz --replace instead.

Also, if you run compiz that way, you should use the nohup command. Otherwise, when you close the terminal, compiz will also be closed. So instead, you'll write:

nohup compiz --replace

Try this and provide some feedback. If it doesn't work, then we'll have another look at it. :)


You might check that window decoration is enabled in Compiz. Run "ccsm" (the Compiz config manager, which should also show up in a menu somewhere).

In the 'Effects' section, the "Window Decoration" feature should be checked. Click the "Window Decoration" box and it's settings appear; in there, the decorator command can be specified. I've read somewhere that some window decorators won't work with compiz, but gtk-window-decorator and compiz-decorator do. Good luck!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.