The Archive Mounter feature in recent Ubuntu editions is great: you just use it on any *.iso file and it mounts it as if you'd put a CD in the drive ... well, almost.

If you want to just read the data, it's great, but if you want to actually execute any programs on it (for instance, to run an old game in wine), you get an error:

The file '/home/{myName}/.gvfs/{myIsoFile}/{myExecutable}.exe' is not marked as executable. If this was downloaded or copied from an untrusted source, it may be dangerous to run. For more details, read about the executable bit.

If you try use the GNOME properties dialog's Permissions tab, it tells you:

The permissions of "/home/{myName}/.gvfs/{myIsoFile}/{myExecutable}.exe" could not be determined.

And if you try to sudo chmod a+x that path, you get:

chmod: cannot access `/home/{myName}/.gvfs/{myIsoFile}/{myExecutable}.exe': Permission denied

So, my question is ... does anyone know how to get ISOs mounted (through the Archive Mounter) AND still be able to execute their contents?

  • possible duplicate of Setting execute permisions on a mounted image – Takkat Aug 20 '11 at 21:03
  • Kinda, but no; that's for other (non-Archive Mounter) ways of mounting. With the Archive Mounter, you have no way to pass options (as suggested by the answer to that question). – machineghost Aug 20 '11 at 22:13
  • the lack of mount options from nautilus "Archive Mount" leads to the solution posted in the answer mentioned above. – Takkat Aug 21 '11 at 8:11
  • If you're referring to answer #2, I missed it and it's ISO Manager suggestion. However, I tried it just now, and even after I add the executable permission to every file in the ISO and re-save then re-mount, I still get the same permissions error. – machineghost Aug 21 '11 at 17:53
  • I am referring to my own answer on a) how to mount an iso executable (bad idea), and b) how to run .exe files for wine without them being executable (good idea). – Takkat Aug 21 '11 at 20:10

I tried to look if gvfs-fuse-daemon uses some kind of "defaults" file to no avail. I know it's not a "gvfs" soluction, but, if it's a problem of exec- property in the mount, you can try the old good command line:

mkdir /tmp/try
sudo mount -o loop,ro,exec,dev /path/to/isofile.iso /tmp/try

I suppose that it could still have problems depending on the type of the filesystem in the iso image.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.