4

Trying to do a release upgrade on Ubuntu 14.04 with:

do-release-upgrade

I get the following error:

It was not possible to authenticate some packages. This may be a transient 
network problem. You may want to try again later. See below for a list of 
unauthenticated packages.

libxkbcommon-x11-0 

What is this about? I did

sudo apt-get update && sudo apt-get dist-upgrade

before and deactivated all ppas. What else could I do?

3

run this command

sudo sh -c 'printf "[Distro]\nAllowUnauthenticated=yes" > /etc/update-manager/release-upgrades.d/unauth.cfg'

this will fix your issue

and after the upgrade run sudo rm /etc/update-manager/release-upgrades.d/unauth.cfg

  • Actually, you need sudo sh -c 'printf "[Distro]\nAllowUnauthenticated=yes" > /etc/update-manager/release-upgrades.d/unauth.cfg' because otherwise the redirection via > is not in the scope of sudo. – tillmo Dec 25 '16 at 16:40
  • Yeah. That's correct. I didn't execute the command. So I realized it after you pointed out the correction. I have updated my answer. Up-vote my answer if possible as it will help users when they have to refer this answer. – Tejus Prasad Dec 29 '16 at 2:05

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.