0

I am having a lot of trouble getting started with an owncloud installation.

I have installed Ubuntu 14.04 server (with Lamp).

The info on the owncloud website seems to produce an error. I tried to use juju but even sudo-add-apt-repository (from get started on https://jujucharms.com/get-started gives a need a repository as argument message).

Basically what is the easiest way to get owncloud installed and I admit I am totally new at this and that the command line "frightens" me?

  • 1
    no need to be frightend of the commandline :) ! And please mark drinxys anwers below as 'accepted' if it worked out for you. best of luck – matv1 Feb 1 '15 at 13:29
0

Modified from owncloud.org:

sudo nano /etc/apt/sources.list.d/owncloud.list

Then paste this into that screen

deb http://download.opensuse.org/repositories/isv:/ownCloud:/community/xUbuntu_14.04/ /

Then update repos and install:

sudo apt-get update
sudo apt-get install owncloud

That should install all the dependencies it needs etc also.

  • I can't actually work out how to access owncloud.org - I have read askubuntu.com/questions/460022/using-terminal-as-a-web-browser and tried w3m and lynx but get "unable to fetch some archives" – Paul Cutler Feb 3 '15 at 11:00
  • did you try to install as per my answer? Also I rarely use terminal to browse sites etc. I generally have an SSH session open to the server I am working on from an Ubuntu desktop. If I need to look for an answer online i use good old firefox and copy/paste commands if i need to. – drinxy Feb 3 '15 at 23:23
  • Yes - nothing seems to happen. When I first login I have paul@ubuntu:~$ at that prompt I type the first line you gave me and it changes to ">" only. I then type the next two lines, nothing happens and I've still got ">" with a blinking _ – Paul Cutler Feb 4 '15 at 11:51
  • @PaulCutler I've updated my answer. It should do the same thing but using a slightly different method. – drinxy Feb 4 '15 at 23:10
  • After the first line sudo nano.... I get a screen with "GNU nano 2.2.6" at the top and a flashing "_" At that flashing cursor I typed your second line deb http://... etc - nothing has happened after that - still just a flashing cursor. I am feeling really inadequate here and totally incapable of doing any of my own problem solving (a bit frustrating - for both of us)! – Paul Cutler Feb 6 '15 at 7:41

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.