1

I try to install some things but i keep getting this error:

Error occured during initialization of VM
Could not reserve enough space for object heap
Could not create the JAVA virtual machine.
dpkg: error processing ca-certificates-java (--configure):
 subprocess installed post-installation script returned error exit status 1.
Errors were encountered while processing:
 ca-certificate-java
E: Sub-process /usr/bin/dpkg returned an error code (1)

What should i do?

| improve this question | | | | |
2

execute

dpkg --force-depends --configure ca-certificates-java

and solve other error appearing

| improve this answer | | | | |
  • Please provide some more information what the command does and how it solves the issue. – Simon Sudler Sep 20 '19 at 7:01
0

You need to first remove ca-certificate-java. After removing i,t you may need to reinstall your java.

Remove it completely using

sudo apt-get purge ca-certificate-java

After it execute

sudo apt-get install -f 

Done

| improve this answer | | | | |
  • After i execute sudo apt-get install -f i get same error. – D3canas Jan 30 '15 at 19:17
  • @D3canas, execute sudo mv /var/lib/dpkg/info/ca-certificates-java.postinst /var/lib/dpkg/info/ca-certificates-java.postinst.bac before the first command and re-execute both commands. – g_p Jan 30 '15 at 19:31
  • then i execute those without space between mv/var i get error: command not found then i execute with scape mv /var i get error: mv: missing destination file operand after:/var/lib/dpkg/info/ca-certificates-java.postinst – D3canas Jan 31 '15 at 9:56
  • @D3canas the whole grayed line is single command . copy from sudo to postinst.bac and execute it. – g_p Jan 31 '15 at 10:01
  • Still getting same error :( Maybe after removing certificates i should reboot or something? – D3canas Jan 31 '15 at 14:23

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.