0

I completely reformatted a drive and set up the partitions as I wanted them.

First I installed Windows 7 and things were smooth (keyboard mouse worked)

Then I installed Ubuntu 14.04 and Grub and things were smooth in ubuntu.

But then, when I chose Windows 7 from GRUB, my mouse and keyboard would both go dark (all the lights on them turn off) and no longer work which leaves me staring at the Windows login unable to interact with everything.

I have poured through my bios and all of my settings there were correct (especially enabling legacy usb and disabling fast boot options). I have tried all of the different usb ports and combos of plugging them in and unplugging them I can think of. My mouse and keyboard both still work in Ubuntu.

Does anyone have an idea why this might happy or how I can resolve it?

(I do not have a ps2 mouse/keyboard on hand but will try to pick one up tomorrow)

  • Have you tried a cold boot? (shut down, unplug batteries and power cords, turn on the machine without power to drain the last electrons, reconnect batteries and power and turn back on). Does that help? – Fabby Feb 2 '15 at 15:05
  • Yeah, tried that and nothing :/ – Robot Rocker Feb 5 '15 at 18:24
1

So I found a solution and I don't know why it fixed it but it did.

I switched GRUB to default to Windows and increased the time defaulting time, as long as I don't enter windows quickly the usb connections work perfectly fine and have been for a week now.

  • 1
    Look if there's a BIOS upgrade. Sounds like a bug in the BIOS. (but still: good find, so an upvote!) – Fabby Feb 5 '15 at 21:07
0

In BIOS, changing the setting for USB initialization from "Partial initialization" to "Full initialization" could resolve the problem.

I've had the same problem and other solutions didn't work out. (Didn't try BIOS update yet)

0

I found something that worked.

I plugged an old PS2 keyboard into my computer and everything returned to normal.

I dont know why or how, but Bios/motherboard/grub seems to treat PS2 keyboard differently than USB keyboard.

0

I had the same issue and none of the other fixes worked. What ended up working, I don't know why, was to put a program into the Windows Startup folder.

In an attempt to do something I put the installer for the network driver into the startup folder, as well as putting a folder that had some items the installer needed. When I rebooted the keyboard and mouse just worked.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.