1

After upgrading to ubuntu 14.10 my MP270 no longer scans. Xsane recognises the scanner but does not scan and give a message "Window is not responding". Simple Scan gives a similar result. Printing still works fine. This has only started happening since upgrading from 14.04. With 14.04 scanning worked perfectly.

  • Use Canon's ScanGear MP from Canon's support website. – s3lph Jan 31 '15 at 22:20
  • Thanks, that seems to have done the trick. All good now. – Terry Dixon Feb 2 '15 at 1:06
1

Some Canon scanners aren't yet fully supported by sane, especially PIXMA MP devices. (got one myself) However, Canon provides its scanning suite ScanGear MP for Linux. You can download it on Canon's support webiste of your country.

In some countries, including the U.S., the software isn't deployed. So here's the downlaod link from the Canon Switzerland support website.

Download the deb package and install it as you would do with any other. (Install with gdebi, USC, or directly with sudo dpkg -i <package_file>)

The package doesn't come with a desktop file, so take the one I made:

Name=Canon ScanGearMP
Exec=/usr/bin/scangearmp
Icon=scanner
Terminal=false
Type=Application
StartupNotify=true
Categories=Graphics

Save it as "scangearmp.desktop" in either /usr/share/applications/ (for all users) or ~/.local/share/applications/ (only for yourself)

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.