Hello 1st time user of Linux and I am using Ubuntu 14.04 and having issues downloading files while using the terminal.

wget "http address"

is no issue but when i attempt to output to a specified folder with

wget -O /home/dizzle/... "http address" 

I get a message just verifying that /home/dizzle/... is a directory.

I havent tried this yet but do I also need to make a filename that it will write to when I use the output command I figured the filename is already placed by the hyperlink.

Im doing this to download adobe AIR with winetricks and getting the adobe AIR 16 executable since the winetrick adobeair command seems to attempt the download from a dead link. If someone knows if I will have trouble installing adobe AIR v16 instead of AIR v4 stop me now lol.


When using wget, the -O option specifies where to download the file to, not the folder. For example, this won't work:

wget -O /path/to/folder http://example.com/

But this will:

wget -O /path/to/folder/filename http://example.com/

Note that I added filename to the end of the path telling it what the file should be called. If you want to download to a specific folder, but use the default file name, pass the -P option.

wget -P /path/to/folder http://example.com/

This will save a file in /path/to/folder with the default name, with the above example, it would be index.html.


You also could try this with tmux once you install tmux with

sudo apt-get update
sudo apt-get install tmux

and then start a tmux session by typing


type your command in the tmux window, Now you don't need to keep your terminal open until it is completed. use Ctrl b+d to exit the tmux session

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.