0

I am trying to get a korean(hangul) text entry working in ubuntu 14.04. So far I installed ibus-hangul and added korean(hangul) to text entry and activated ibus in the language settings.

Now I experience the following.

If I click on the symbol in the right corner and click on keyboard layout for korean(hangul) it shows me the standard English(USA) layout.

Then I depending on whether ibus is activated or not, I can only enter korean(hangul), e.g. in firefox or libre writer, or not at all. I can never change from korean(hangul) to standard English.

Now the surprising thing is that everything works fine in the unity search thing. Here, I can switch between my differtent text entry options.

I would appreciate any help, since I remember having such problems with every version of ubuntu.

  • dont you need a keyboard thats multilingual enabled? – Virusboy Jan 29 '15 at 17:36
0

14.04 uses ibus-hangul 1.4.2-3, which unfortunately does not have the ability to switch between Korean and English within the input method.

To switch between English and Korean, you would need to switch the input method entirely using the indicator menu or using:

Super + space to cycle through your input sources and Shift + Super + space to cycle in reverse.

14.10 uses ibus-hangul 1.4.2+git20140818-1, which has added the ability to switch between English and Korean within the input method.

  1. Choose Hangul from the ibus indicator.
  2. Open the drop-down and choose Setup.
  3. Look at the keybindings to toggle between English and Hangul while in Korean input. The default on an English language keyboard is Shift + space. You can change this to whatever works best for you.

IbusHangul Setup

If you prefer menus to keyboard shortcuts, you can also check/uncheck Hangul mode in the ibus indicator drop-down when Korean is activated.

To start with Hangul rather than English, check the Start in Hangul mode option in the setup.

  • Thanks for answering. The problem is that the setup menu above in my case is exaclty missing the hangul toggle key and the "Start in hangul mode" point. – André Betz Feb 1 '15 at 23:06
  • I'm sorry. I was using 14.10 when using ibus-hangul the first time. I updated the answer. – chaskes Feb 2 '15 at 3:05

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.