51

Some time ago I created a VPN connection using Ubuntus own Network Manager, which worked fine! Now, a few months later, I want to go in and edit the connections details, but instead I get this error: unable to load VPN connection editor.

enter image description here

Any idea how this could be solved?

[UPDATE] Starting the connection manager manually with nm-connection-editor lets you edit the settings, but that still leaves the original error.

1
  • 3
    Do not go on Network setting in NM, go on Network Connections. Find connection in list, select, go right on edit
    – 2707974
    Jan 29, 2015 at 11:56

6 Answers 6

78

Run

sudo apt-get install openvpn network-manager-openvpn network-manager-openvpn-gnome

This will prompt for both your password, and a Y/n answer, please provide it with your password, and Y.

1
  • 11
    Yes, my issue was that I had only network-manager-openvpn, but not network-manager-openvpn-gnome installed.
    – Mitar
    Feb 3, 2018 at 3:13
18

If you use a vpnc connection, like with FritzBox routers, run

sudo apt install network-manager-vpnc network-manager-vpnc-gnome
8

The answers are quite specific. What helped me was indeed:

  1. Running nm-connection-editor from the terminal

  2. The following warning gives you the hint to the missing dependency

Could not load editor VPN plugin for “org.freedesktop.NetworkManager.XYZ” (missing plugin file "/usr/lib/x86_64-linux-gnu/NetworkManager/libnm-vpn-plugin-XYZ-editor.so").

  1. Install the missing dependency via sudo apt-get install network-manager-XYZ-gnome, i.e. using one of
  • network-manager-l2tp-gnome
  • network-manager-openconnect-gnome
  • network-manager-pptp-gnome
  • network-manager-vpnc-gnome
  • network-manager-openvpn-gnome
  • ...

With the missing /usr/lib/x86_64-linux-gnu/NetworkManager/libnm-vpn-plugin-XYZ-editor.so now installed on your system, the network editor will continue working like a charm.

1
  • the other answers were helpful, but this was the actual key for me too... nothing else indicated i needed "network-manager-openconnect-gnome". Once installed, it brought up the interface I needed for cisco anyconnect. The problem was I did not realize that I didn't have the proper GUI, because the menu option was there and opened the wrong one. Just a note: I had to cross reference (through googling) the error message with packages.ubuntu.com/focal/all/network-manager-openconnect-gnome/… to understand your comment... but now i see what was ACTUALLY missing. Thanks
    – WU-TANG
    Aug 14, 2020 at 16:43
4

Try this:

sudo apt-get install network-manager-pptp-gnome
3
  • 6
    can you explain why this could help?
    – Zanna
    Apr 26, 2017 at 6:40
  • 1
    It is useful when we use a Point-to-Point Tunneling Protocol and not OpenVPN. ;)
    – J-Jamet
    Sep 28, 2018 at 7:56
  • Exactly what I needed. I knew what was going on with the pptp package, but thanks for explaining it as well anyway. Mar 15, 2019 at 16:10
2

I have had a similar issue on Ubuntu 18.04 which persisted after installing all the dependencies listed in other answers.

Starting nm-connection-editor from terminal logged the warning below

** (nm-connection-editor:8495): WARNING **: 19:18:23.811: Could not load editor VPN plugin for “org.freedesktop.NetworkManager.l2tp” (missing plugin file "/usr/lib/x86_64-linux-gnu/NetworkManager/libnm-vpn-plugin-l2tp-editor.so").

and the answer to that was

sudo apt install network-manager-l2tp-gnome
sudo service network-manager restart

as given in How do I connect to L2TP over IPsec using Network Manager?.

2

On Ubuntu 20.04 it was network-manager-openconnect-gnome:

sudo apt install network-manager-openconnect-gnome

https://bugs.launchpad.net/ubuntu/+source/network-manager-openconnect/+bug/1872074

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.