4

When I type gedit in my terminal, I get:

daniel@daniel-pc:~$ gedit
The program 'gedit' is currently not installed. You can install it by typing:
sudo apt-get install gedit

So I do that:

daniel@daniel-pc:~$ sudo apt-get install gedit
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 gedit : Depends: gedit-common (< 3.11) but 3.12.2-0ubuntu1~trusty1 is to be installed
E: Unable to correct problems, you have held broken packages.
daniel@daniel-pc:~$ 

Background:

I followed all the code seen at http://howtoubuntu.org/things-to-do-after-installing-ubuntu-14-10-utopic-unicorn, but after I noticed that many basic programs (like getedit and nautilus) had the gnome style instead of the unity style, I removed the PPAs from the GUI software and Updates.

I also sudo apt-get install edubuntu-desktop-ed to get the programs found in edubuntu, but after it changed the theme and backgrounds I followed the instructions here: How remove all programs comes from a package?, selecting programs I did not want from the list that it returned. I run

daniel@daniel-pc:~$ apt-cache show gedit
Package: gedit
Priority: optional
Section: gnome
Installed-Size: 2615
Maintainer: Ubuntu Desktop Team <ubuntu-desktop@lists.ubuntu.com>
Original-Maintainer: Debian GNOME Maintainers pkg-gnome-maintainers@lists.alioth.debian.org
Architecture: amd64
Version: 3.10.4-0ubuntu6
Depends: libatk1.0-0 (>= 1.12.4), libc6 (>= 2.14), libcairo2 (>= 1.2.4), libenchant1c2a (>= 1.6.0), libgdk-pixbuf2.0-0 (>= 2.22.0), libgirepository-1.0-1 (>= 0.9.3), libglib2.0-0 (>= 2.38), libgtk-3-0 (>= 3.10), libgtksourceview-3.0-1 (>= 3.10.1), libpango-1.0-0 (>= 1.14.0), libpeas-1.0-0 (>= 1.1.0), libx11-6, libxml2 (>= 2.7.4), libzeitgeist-2.0-0 (>= 0.9.9), gedit-common (>= 3.10), gedit-common (<< 3.11), gsettings-desktop-schemas, python3-gi (>= 3.0), python-gi-cairo (>= 3.0), gir1.2-peas-1.0, iso-codes
Recommends: gir1.2-gtksource-3.0, zenity, yelp
Suggests: gedit-plugins
Breaks: gedit-plugins (<< 2.91)
Filename: pool/main/g/gedit/gedit_3.10.4-0ubuntu6_amd64.deb
Size: 483208
MD5sum: 3e4508090c23d68053212ab02cb0287c
SHA1: 9f38aafddfa21cd2743b863b1783710a5360d0d2
SHA256: d43073382e1b9894abecfcd8fe6a04e2c771f6aabe0891e666a8f59ee2107283
Description-en: official text editor of the GNOME desktop environment
 gedit is a text editor which supports most standard editor features,
 extending this basic functionality with other features not usually
 found in simple text editors. gedit is a graphical application which
 supports editing multiple text files in one window (known sometimes as
 tabs or MDI).
 .
 gedit fully supports international text through its use of the Unicode
 UTF-8 encoding in edited files. Its core feature set includes syntax
 highlighting of source code, auto indentation and printing and print preview
 support.
 .
 gedit is also extensible through its plugin system, which currently
 includes support for spell checking, comparing files, viewing CVS
 ChangeLogs, and adjusting indentation levels.
Description-md5: 5091aaf6659e6bf7ca9b32695a59f9cd
Homepage: http://www.gnome.org/projects/gedit/
Bugs: https://bugs.launchpad.net/ubuntu/+filebug
Origin: Ubuntu
Supported: 9m
Task: ubuntu-desktop, ubuntu-usb, edubuntu-desktop, edubuntu-usb, ubuntustudio-desktop, ubuntu-gnome-desktop, ubuntukylin-desktop

daniel@daniel-pc:~$

So it says gedit is installed, but it isn't. I tried to uninstall the Gnome version of gedit by doing `sudo apt-get remove gedit=' and the version number, but I don't remember it.

EDIT:

daniel@daniel-pc:~$ apt-cache policy gedit-common
gedit-common:
  Installed: 3.12.2-0ubuntu1~trusty1
  Candidate: 3.12.2-0ubuntu1~trusty1
  Version table:
 *** 3.12.2-0ubuntu1~trusty1 0
        100 /var/lib/dpkg/status
     3.10.4-0ubuntu6 0
        500 http://us.archive.ubuntu.com/ubuntu/ utopic/main amd64 Packages
daniel@daniel-pc:~$

EDIT: Image of nautulus now, which is what gedit looked like before uninstall: link look at the menu bar. It lookes like gnome, not default unity. Also I would like a general solution for all programs affected by this, not just gedit and nautilus (though I don't know if there are any).

3
  • It seems some third party ppa (probable gnome ppa) is still active. Post the output of apt-cache policy gedit-common. – g_p Jan 29 '15 at 5:15
  • @david: please refrain from editing for minute changes like adding 1 tag to a question... Better to edit questions that have grammar/spelling/readability problems... That way you help the entire community! ;-) – Fabby Jan 29 '15 at 11:39
  • @g_p added requested info – dzil123 Jan 30 '15 at 1:52
2

First run

sudo apt-get purge gedit gedit-common
sudo apt-get clean

Then after install gedit using

sudo apt-get install gedit

It should work.

6
  • Would I do the same thing for nautilus? – dzil123 Jan 30 '15 at 3:59
  • I am not sure, because you have not mention package detail of nautilus. Better ask a separate question with all the detail of error while installing nautilus. – g_p Jan 30 '15 at 4:33
  • Its just that nautilus and archive manager and probably others are affected. Do you know if I can purge them and re install? – dzil123 Jan 30 '15 at 4:47
  • It should work. Give it a try but be careful while purging the package because you may remove some necessary package too. – g_p Jan 30 '15 at 4:49
  • 1
    @dzil123, First see here.If it does not help you please ask a new question,we will definitely help you. – g_p Jan 31 '15 at 5:28

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.