0

So as I have been installing my LAMP stack, I looked up my IP address at www.icanhazip.com, and attempted to load http://server-ip-address/phpmyadmin/ and it will not load the phymyadmin login page. It just thinks and thinks and thinks...

When I go back over various ways to get Drupal running on Ubuntu14.04, there is this article: Install phpmyadmin in Ubuntu

After I supposedly "Configure Apache2 for phpmyadmin" in step 3, I am prompted to restart:

sudo service apache2 restart

I get the following return:

* Restarting web server apache2                                     [fail] 
 * The apache2 configtest failed.
Output of config test was:
apache2: Syntax error on line 223 of /etc/apache2/apache2.conf: Could not open configuration file /etc/phpmyadmin/apache2.conf: No such file or directory
Action 'configtest' failed.
The Apache error log may have more information.

This is with the end goal of creating a Drupal site with a cheap web hosting service that does not include Drupal pre-installed. As such, I used some code of all the php packages I could need for Drupal:

sudo apt-get install php5 php5-mysql php5-curl php5-gd php5-intl php-pear php5-imagick php5-imap php5-mcrypt php5-memcache php5-ming php5-ps php5-pspell php5-recode php5-snmp php5-sqlite php5-tidy php5-xmlrpc php5-xsl

I got no complaints from terminal, but maybe this was too much?

One more thing, do I need hosting service to test phpmyadmin? Is that what is meant by server-ip-address in the various descriptions of how to get phpmyadmin running? Or just the local ip address of your machine... I should know better, but its not working to give me feedback on which, and this type of question is breathtakingly vague for google...

Edit: I hoped that a simple purge would do it, with a different good luck charm, but it is not working. Elsewhere on the web the combined methods were recommended, but still it posts this error.

1 Answer 1

1
sudo apt-get purge apache2
sudo apt-get install apache2

This will recover Apache.

sudo apt-get install php5 libapache2-mod-php5 php5-mcrypt php5-mysql

PHP installed.

http://www.phpmyadmin.net/home_page/index.php

Download phpMyAdmin from here, unzip, copy all files to /var/www/html/phpmyadmin/

http://localhost/phpmyadmin/

Enter your mysql credentials.

8
  • 1
    I do not know how to create a folder using sudo in files needing root access, nor do I know how to copy over files to root access folders, or unzip things. I tried: sudo apt-get install phpmyadmin, but the error still shows, after purging, also after adding ServerName localhost to the apache2.conf file. Jan 29, 2015 at 3:34
  • just type: "sudo nautilus" it will give you a file explorer with root privileges Jan 29, 2015 at 22:52
  • I was unclear about whether Mehmet intended me to copy all files to /var/www/html/phpmyadmin/, as what unzipped was another "phpmyadmin" folder with the version number, which would make it nested... Should I remove the folder with the version name, add phpmyadmin, or extract as is, to form /var/www/html/phpmyadmin/(lots of stuff), /var/www/html/ phpmyadmin/phpMyAdmin-4.3.8-all-languages/(lots of stuff),or phpMyAdmin-4.3.8-all-languages/(lots of stuff)? Edit: I should add that I used sudo apt-get install, but folders are still empty, phpmyadmin is already installed... Feb 1, 2015 at 4:49
  • This link should work then. For being more organized and proper link move all files in /var/www/html/phpmyadmin/phpMyAdmin-4.3.8-all-languages/ to upper directory. Feb 1, 2015 at 4:57
  • umm, I think I will need to create a new question, but the link seems to work, but whether I shift around the contents and link this way or that way, if it works, what shows is not the homepage I have seen before, but something that starts with: addJSON( 'options', PMA_RecentTable::getInstance()->getHtmlSelectOption() ); exit; } if ($GLOBALS['PMA_Config']->isGitRevision()) { if Feb 1, 2015 at 5:19

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .