2

I borked my install of Ubuntu 14.04 LTS and had to reinstall the OS. I didn't tinker with my /home partition, just reinstalled the OS to the /root partition.

When I download and install HPLIP 3.14.10 from the HP website, no matter how many times I run the setup GUI, I end up with the same error. To retrace my steps,

  • I select Network/Ethernet/Wireless/ option and click Next.
  • My device (HP Color LaserJet Pro MFP M177fw) is recognized and I press the Next button
  • I select Download and Install ... and press Next
  • Error Message: /home/****/.hplip/hplip-3.14.10-plugin.run file does not match its checksum.File may have been corrupted or altered

Used sudo to copy the relevant .ppd files (printer and fax) from my 14.04 LTS laptop to /etc/cups/ppd but the setup won't recognize .ppd files, only .run files.

Does any one have any ideas of what I can do? Is there a way to download the appropriate .run file(s) outside setup? BTW, I have no "checksum" data in the ~./hplip folder ... so I don't know what setup is using as the compare.

Please help. I'm desperate because this is my work computer and I need to be able to print and scan to earn a living.

Thanks, mojohn

P.S. I downloaded the plugin and checksum from www.openprinting.org/download/printdriver/auxfiles/HP/plugins/ and ran a compare. The following error was reported: gpg: can't open `hplip-3.14.10.run.asc' gpg: verify signatures failed: file open error

Got the same error when I ran a compare on 3.14.6 and 3.14.1. Appears there is something amiss at the website.

Maybe that helps??

  • 2
    Welcome to ask Ubuntu. Please do not put FIXED/SOLVED etc in the subject header of your question. You can answer your own question below where it says Your Answer. then you can accept your own answer by putting a green check mark next to it to mark it as "fixed." – user68186 Jan 28 '15 at 21:33
  • @mojohn: Could you please convert that to an answer so that schmucks like me who go around hunting for unanswered questions don't have to look at this one any more. ;-) (And I'll upvote if you drop me a note and it's a good one too!) – Fabby Jan 30 '15 at 22:24
1

Answer from OP:

I copied the 3.14.10 plugin to ~/.hplip and ran setup again. Setup complained that it couldn't verify the checksum, but asked if I wanted to install the file anyway. I clicked yes, and the install finished.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.