2

I'm pretty new to Ubuntu but keen on coming to grips with it. I've tried to install Everpad on Ubuntu 14.04. The repository was added to source.list and the repository key was registered as well.

There is an unmet dependency. Any idea how I could get the libgtk2.0-0 issue resolved? Thus far I refrained from forcing apt-get to install everpad regardless of missing dependencies.

My Ubuntu updates daily and I haven't protected libgtk2.0-0 from being updated in aptitude.

$ sudo apt-get install everpad
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
everpad : Depends: gtk2-engines-pixbuf but it is not going to be installed
E: Unable to correct problems, you have held broken packages.

$ sudo apt-get install gtk2-engines-pixbuf
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:
The following packages have unmet dependencies:
 gtk2-engines-pixbuf : Depends: libgtk2.0-0 (= 2.24.23-0ubuntu1) but  
2.24.23-0ubuntu1.1 is to be installed
E: Unable to correct problems, you have held broken packages.

$ sudo apt-get install libgtk2.0-0
Reading package lists... Done
Building dependency tree       
Reading state information... Done
libgtk2.0-0 is already the newest version.
0 upgraded, 0 newly installed, 0 to remove and 2 not upgraded.
1

I solved the dependency issue using aptitude to downgrade 4 libraries. Aptitude will show solutions for the problem and accepting the one which downgrades solved it.

Here is more information about aptitude general aptitude how-to guide

Everpad is working fine now.

| improve this answer | |
  • Which packages did you downgrade? – Ron Romero Mar 11 '16 at 15:02
0

I recently had the same problem; I found out that I had to enable recommended updates (trusty-updates in ubuntu 14.04) in software update (updates tab); this allow the system to download latest versions of packages;

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.