I Have installed Linux 14.04 lts. I am getting interface device name as em1 and eth0.I want to rename it as eth0 and eth1.


Best way to achieve that what you are looking for:

First, uninstall the package biosdevname

sudo apt-get remove biosdevname

then run

sudo update-initramfs -u

After the next boot, everything will work the good ol way.

  • 2
    This worked for me. That package biosdevname must have been included as part of a recent apt-get upgrade I performed. – paperclip Aug 19 '15 at 13:15

Edit /etc/default/grub and search for the following:


Add biosdevname=0 to the 2 lines:


Then run

sudo update-grub

Finally reboot, after reboot you should find all rules persisted in /etc/udev/rules.d/70-persistent-net.rules

  • On Ubuntu 14.04 there is no grub file at that location, its found in /boot/grub/grub.conf. The solution that worked for me was by @oler askubuntu.com/a/620678 – paperclip Aug 19 '15 at 13:14
  • Do you need to set biosdevname=0 on both LINUX_DEFAULT and LINUX? the resulting grub.cfg has two biosdevname=0. Althought that shouldn't be a problem, I think you should be able to set either of the lines ;) – Heartinpiece Oct 3 '16 at 6:40

Edit 70-persistent-net.rules

vi /etc/udev/rules.d/70-persistent-net.rules    

Locate in the file the hardware named em1 and replace with eth*

Save and reboot

  • I have added this content to /etc/udev/rules.d/70-persistent-net.rules SUBSYSTEM=="net", ACTION=="add", DRIVERS=="?*", ATTR{address}=="00:10:b5:f5:b7:31", ATTR{dev_id}=="0x0", ATTR{type}=="1", KERNEL=="eth*", NAME="eth0". and then saved and rebooted as you said but it is not happening. – amitabh sinha Jan 28 '15 at 5:52
  • You don't have to add anything, you should replace the line were em* was with eth* . Here is a little tutorial upubuntu.com/2013/03/… – Jorge Buchmann Jan 28 '15 at 11:37

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.