1

I have recently been trying to access a remote directory over davfs2, and I have been running into quite a bit of trouble trying to make it work. After struggling with some crashes due to (apparently) corrupted davfs2.config file, I purged davfs2 from my system and reinstalled. This replaced my davfs2.config file back to the original. However, now when I execute the mount I get

mount -t davfs http://www.box.com/dav /media/user@box/
/sbin/mount.davfs: group davfs does not exist

Any suggestions on how to add the davfs group?


thanks for you continued assistance. I modified the mount call like you showed, and it still throws the same error as before:

$ sudo mount -t davfs https://dav.box.com/ /media/user@box/
/sbin/mount.davfs: group davfs does not exist

The df -h command you suggested didn't show any additional mounts in /media/user@box/

$ df -h
Filesystem            Size  Used Avail Use% Mounted on
/dev/sda3             100G   48G   47G  51% /
none                  4.0K     0  4.0K   0% /sys/fs/cgroup
udev                  3.7G  4.0K  3.7G   1% /dev 
tmpfs                 751M  1.5M  750M   1% /run
none                  5.0M     0  5.0M   0% /run/lock
none                  3.7G   12M  3.7G   1% /run/shm
none                  100M   44K  100M   1% /run/user
/home/user/.Private  100G   48G   47G  51% /home/user

I verified that I have ownership of the "/media/user@box/ folder:

$ ls -a -l
total 16
drwxr-xr-x   4 root  root  4096 Jan 27 23:13 .
drwxr-xr-x  25 root  root  4096 Jan 21 20:50 ..
drwxr-x---+  2 root  root  4096 Jan 26 23:41 user
drwxr-xr-x   4 mikey mikey 4096 Jan 27 14:04 user@box

but there is no /user@box/dev/ upload directory as you mentioned was on your system. Perhaps there is some set-up step to 'initialize' the /user@box/ directory to mount box to it? Beyond setting ownership?

One quick note, I feel fairly certain I have been to this point in the past and then tried to 'reset' and start from scratch again. It is possible that I made a mistake with some settings in the past and would need somehow reset. Is there any way to trace an error log? Any additional suggestions would be greatly appreciated.

edit: I tried modifying the /etc/fstab file as you suggested and when I run '$sudo mount -a' I get the same error as before.

4

When you installed davfs2 it should have created the group, so I think the issue is your not a member of the group

 sudo adduser username davfs2

Then log out and in again.

Edit

So it seems they have made some changes on their end. This is how I was able to get it setup and working

 sudo apt-get install davfs2

Then create a mount point

 sudo mkdir /media/user@box.com

Here is where the difference is

To mount the drive you need to run the command

  sudo mount -t davfs https://dav.box.com /media/user@box.com

It will then prompt you for your username and then your password

You should now be mounted.

You can verify this by the fact that you receive no error message and if you run

 df -h 

you should see

 https://dav.box.com   10G     0   10G   0% /media/user@box.com

Edit 2

Don't forget to chown the mount point to user, otherwise you will need to use sudo. Substitute user:user with your own Ubuntu username

 sudo chown -R user:user /media/user@box.com

I got an error

 chown: changing ownership of ‘user@box.com/lost+found’: Invalid argument

but it did change ownership of user@box.com as well as user@box.com/dav (the upload directory)

Edit 3

Just in case you need. You can add your password to secrets file so don't need to enter all the time. Plus this will also make it easier to auto mount with fstab.

 sudo nano /etc/davfs/secrets

add the following to the end of the file

 https://dav.box.com/dav username password

Now if you want the drive auto mounted at startup (I'm sure you do) you just need to add the following to

 sudo nano /etc/fstab

 https://dav.box.com/dav /media/user@box.com  davfs  _netdev,rw,user 0 0

If you still have the drive mounted go ahead and unmount it by using

 sudo umount /media/user@box.com

Now you can verify that the mount will auto mount at start by running

 sudo mount -a

and then

 df -h 

to verify you see

 https://dav.box.com/dav   10G     0   10G   0% /media/user@box.com

If this works for you, please be sure to mark the answer as accepted so we both get credit and more importantly, so the next person that comes along knows it's a working solution.

  • Thanks for the tip. I tried adding the user and it said I was already a member of the group. I have logged in/out several times and also reset the computer, but the problem persists. – MicahJ Jan 28 '15 at 2:49
  • @MicahJ I got it working on my end. See my updated answer. – geoffmcc Jan 28 '15 at 3:24

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.