5

I've got a new x1 carbon and the track point works as a moving mouse, but the new hardware buttons for right and left click do not function. When I click the left one, the page scrolls up a few lines. When I click the right one, it scrolls down a few lines.

Any hints on how to force the buttons into the right function?

xev lists the left/right buttons as button 4 and 5.

% xinput list-props "TPPS/2 IBM TrackPoint"
Device 'TPPS/2 IBM TrackPoint':
    Device Enabled (136):   1
    Coordinate Transformation Matrix (138): 1.000000, 0.000000, 0.000000, 0.000000, 1.000000, 0.000000, 0.000000, 0.000000, 1.000000
    Device Accel Profile (260): 0
    Device Accel Constant Deceleration (261):   1.000000
    Device Accel Adaptive Deceleration (262):   1.000000
    Device Accel Velocity Scaling (263):    10.000000
    Device Product ID (254):    2, 10
    Device Node (255):  "/dev/input/event12"
    Evdev Axis Inversion (304): 0, 0
    Evdev Axes Swap (306):  0
    Axis Labels (307):  "Rel X" (146), "Rel Y" (147)
    Button Labels (308):    "Button Left" (139), "Button Middle" (140), "Button Right" (141), "Button Wheel Up" (142), "Button Wheel Down" (143), "Button Horiz Wheel Left" (144), "Button Horiz Wheel Right" (145)
    Evdev Scrolling Distance (309): 0, 0, 0
    Evdev Middle Button Emulation (310):    1
    Evdev Middle Button Timeout (311):  50
    Evdev Third Button Emulation (312): 0
    Evdev Third Button Emulation Timeout (313): 1000
    Evdev Third Button Emulation Button (314):  3
    Evdev Third Button Emulation Threshold (315):   20
    Evdev Wheel Emulation (316):    1
    Evdev Wheel Emulation Axes (317):   6, 7, 4, 5
    Evdev Wheel Emulation Inertia (318):    10
    Evdev Wheel Emulation Timeout (319):    200
    Evdev Wheel Emulation Button (320): 2
    Evdev Drag Lock Buttons (321):  0

% xinput get-button-map 12 1 2 3 4 5 6 7

I've tried setting all of the button to 1 but that failed to work to enable the proper left-click on the button press.

Thanks for the tips/help.

UPDATE: I turned off the trackpad in the bios and it did not shut off. It worked when I did a boot which surprised me. I then went back into the bios and disabled both the trackpad and the trackpoint and only the trackpoint was disabled. The trackpad still functioned properly.

This led me to think it might be a hardware issue, after getting the run around with lenovo support, who would not work with me without windows running, I booted a windows install usb disk and sure enough the trackpad was disabled.

This seems amazingly odd to me that a setting in the bios is or is not listened to on the OS side, but it might be a hint that there's a need for some sort of new/updated driver in Ubuntu to get this to work out?

  • Does Lenovo have a BIOS update for you? – Elder Geek Feb 9 '15 at 0:10
  • Any luck fixing this issue, I have the same laptop model and I can't seem to be able to use the middle button to scroll – Calin Feb 24 '15 at 19:51
3

It's a known bug that has a fix being pushed very soon. https://bugs.freedesktop.org/show_bug.cgi?id=88609

2

I finally got this working by updating to kernel 3.19 and editing a xorg conf file

Update the kernel using this tutorial:

http://www.linuxandubuntu.com/home/linux-kernel-3-19-stable-released-install-upgrade-in-ubuntu-linux-mint

Then edited /usr/share/X11/xorg.conf.d\11-evdev-trackpoint.conf upated the line:

MatchProduct    "TrackPoint|DualPoint Stick"

to

MatchProduct    "TrackPoint|DualPoint Stick|PS/2 Synaptics TouchPad"

Running Ubuntu 14.04

  • You're my hero. Middle scroll ftw! – Rick Feb 25 '15 at 1:54
  • Updating the kernel did it for me, though it broke my wifi on Linux Mint, which I then fixed by installing the latest network drivers. – Severyn Kozak Jul 3 '15 at 1:37
1

Add this to /etc/rc.local:

modprobe -r psmouse
modprobe psmouse proto=imps

Then reboot.

0

Everything you need for an X1 Carbon 2015 3rd generation can be found here: Lenovo X1 Carbon 2015 3rd gen 20 BS - trackpoint, clickpad and wifi

protected by Community May 5 '15 at 3:58

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.