This question already has an answer here:

I've been using Ubuntu Server for a few months now.
I'm getting the below OUTPUT after running sudo apt-get -f upgrade:

Reading package lists... Done
Building dependency tree       
Reading state information... Done
Calculating upgrade... Done
The following packages will be REMOVED
0 to upgrade, 0 to newly install, 1 to remove and 0 not to upgrade.
2 not fully installed or removed.
After this operation, 152 MB disk space will be freed.
Do you want to continue? [Y/n] y
(Reading database ... 447185 files and directories currently installed.)
Removing linux-image-extra-3.13.0-44-generic (3.13.0-44.73) ...
run-parts: executing /etc/kernel/postinst.d/apt-auto-removal 3.13.0-44-generic /boot/vmlinuz-3.13.0-44-generic
run-parts: executing /etc/kernel/postinst.d/initramfs-tools 3.13.0-44-generic /boot/vmlinuz-3.13.0-44-generic
update-initramfs: Generating /boot/initrd.img-3.13.0-44-generic

gzip: stdout: No space left on device
E: mkinitramfs failure cpio 141 gzip 1
update-initramfs: failed for /boot/initrd.img-3.13.0-44-generic with 1.
run-parts: /etc/kernel/postinst.d/initramfs-tools exited with return code 1
dpkg: error processing package linux-image-extra-3.13.0-44-generic (--remove):
 subprocess installed post-removal script returned error exit status 1
Errors were encountered while processing:
E: Sub-process /usr/bin/dpkg returned an error code (1)

I've tried all the Google results I can find that seem relevant including sudo apt-get remove and sudo apt-get autoremove, but to no avail.

marked as duplicate by Eric Carvalho, Elder Geek, Fabby, v2r, waltinator Feb 9 '15 at 16:56

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

  • As you can see in the output, your root partition is full (gzip: stdout: No space left on device). You need to create some space. Here are some possible way to do it. – g_p Jan 27 '15 at 16:20
  • Thanks both. I think there was a problem with the boot space, however, I was trying to clear space but it wouldn't let me. The first time I tried to use the sudo apt-get -y purge command it wouldn't let me, but I tried a few different things with seemingly no success, went back to that command, and then it worked? Sorry I can't be more specific but I'd typed so many commands in from the forums I'm not sure which one did what! :) Thanks for all your help. – nathanjfield Jan 28 '15 at 8:23
  • OK, as reported, I managed to free up the disk space & update/upgrade. When I went into Ubuntu Software Manager it asked me to install an update and then reboot, which I did. However, once I did that, I lost my network connection, and I can't get it back! Network manager is installed, and everything looks OK, but ifconfig shows: inet addr: – nathanjfield Jan 28 '15 at 11:54
  • @nathanjfield We are glad you were able to update and upgrade (which effectively solves this question). Your ip address question is different and unrelated and won't get much attention here in the comments. Please search for your problem among the existing questions and if you can't find it ask a new one. Thank you for helping us help you! – Elder Geek Jan 31 '15 at 2:41
  • Thanks @ElderGeek, I already have and got a solution here. – nathanjfield Feb 2 '15 at 8:14

This was fixed due to the help of @g_p and @muru, who pointed out the low disk space issue. Specifically @muru's link helped a lot. Be careful though, that you don't do what I did, and end up removing files that are actually important to the running of the PC (like the network). :)

Not the answer you're looking for? Browse other questions tagged or ask your own question.