I can't install Ubuntu 14.04.1 LTS because system restarts as I choose to install alongside windows 7 and press continue till then everything goes fine. I tried many times but I didn't get success. Please help as soon as possible.

  • What if you choose Something Else and select the partition manually?
    – g_p
    Jan 27, 2015 at 9:53
  • @g_p what if it wipe out everything ?
    – Waqas
    May 21, 2015 at 10:10
  • It won't. Select the partition in which you want to install, format it if needed and install in it.
    – g_p
    May 21, 2015 at 10:16
  • I dont have any partition which I can format but I have space in where I want to install it best case would be installing it alongside windows 7 and if i try it says no root file system is defined please correct this from the partitioning menu
    – Waqas
    May 21, 2015 at 10:18

1 Answer 1


Do the following:

1-In windows 7 free up some space for Ubuntu. Keep at least 30 GB. Keep this space unallocated. Don't make it into a separate partition. You can create a separate partition using Disk Management utility of windows.

2-Now try installing but instead of choosing Install alongside Windows 7 choose Something Else

3-In there you locate the unallocated space, select it, and press the + button.

4-In the drop down list you will find option Swap Area or something like that, choose it, and make the size near about the size of your RAM, and click OK.

5-If you have a GPT disk you will have to create boot area. Not sure create anyway. It does no harm. For creating boot area select the remaining unallocated space,click +, choose Ext4 and choose the mount point as /boot. Give 1 GB max to /boot.

6-Now create the main root area. Select the remaining unallocated space, select '+', Choose Ext4, take the max size available, aand choose mount point as /.

7-Click next or continue. It might show a warning message or something. Click OK.


  • Well, why alongside wont work ? Why it just keep restarting whenever you choose Install Alongside windows 7
    – Waqas
    May 21, 2015 at 10:14

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.