I have Pepper Flash Plugin installed, but it doesn't work on chromium and still every webpage prompts to install Adobe flash.

I removed and installed it again but nothing changed. I'm sure it's installed because with attempt to new install get this message:

sudo apt-get install pepperflashplugin-nonfree

Reading package lists... Done
Building dependency tree       
Reading state information... Done
pepperflashplugin-nonfree is already the newest version.
0 upgraded, 0 newly installed, 0 to remove and 6 not upgraded.

Ps. This is how I removed the plugin before installing it again:

apt-get remove --purge pepperflashplugin-nonfree

Reading package lists... Done
Building dependency tree       
Reading state information... Done
The following packages will be REMOVED:
0 upgraded, 0 newly installed, 1 to remove and 6 not upgraded.
After this operation, 66.6 kB disk space will be freed.
Do you want to continue? [Y/n] y
(Reading database ... 199594 files and directories currently installed.)
Removing pepperflashplugin-nonfree (1.3ubuntu1) ...
Purging configuration files for pepperflashplugin-nonfree (1.3ubuntu1) ...

apt-get clean


  • With what command did you remove it with the use of? – user364819 Jan 26 '15 at 21:55
  • @Toroidal sudo apt-get remove --purge pepperflashplugin-nonfree then sudo apt-get clean – DummyBeginner Jan 26 '15 at 21:59
  • And what was the output of that command? – user364819 Jan 26 '15 at 22:14
  • 2
    you can save your tendons some by typing sudo apt-get purge instead of sudo apt-get remove --purge – mchid Jan 26 '15 at 22:22
  • @Toroidal I added it to question, Thanks – DummyBeginner Jan 26 '15 at 22:23

Despite what was said on Ubuntu wiki and here to simply install flash on Chromium by pepperflashplugin-nonfree package; I was forced to manually copy the pepperflash plugin file from Google chrome to chromium in the way expounded here :

Download Google Chrome and extract libpepflashplayer.so from /opt/google/chrome/PepperFlash in the Chrome deb file Copy libpepflashplayer.so to /usr/lib/chromium-browser/plugins Make the necessary changes to the Chromium startup

sudo gedit /etc/chromium-browser/default

Add this to the CHROMIUM_FLAGS

CHROMIUM_FLAGS="--ppapi-flash-path=/usr/lib/chromium-browser/plugins/libpepflashplayer.so --ppapi-flash-version="

You can get the correct version of the flash plugin from the "version": json tag in the mainfest.json from /opt/google/chrome/PepperFlash in the Chrome deb file

Now I have Adobe Flash Player - Version: on Chromium and it works fine. I don't know if I could get updates for flash on Chromium using this on Trminal:

sudo update-pepperflashplugin-nonfree --status

Because it doesn't give anything on Terminal.

If you have any idea of how to keep the flash player updated on Chromium (without manually copying .so file eachtime a new version is released);

Also about the reason of pepperflashplugin-nonfree didn't copy the plugin file in Chromium folder or didn't update CHROMIUM_FLAGS="" in /etc/chromium-browser/default automtically, please let me know in comments.


  • 2
    This is just an idea how to deal with the update problem: instead of copying the plugin files to the chromium location, create a symbolic link to the file. – user23573 Oct 25 '15 at 18:25
  • @BogdanWilli Hmm, interesting. I'll try that. Thanks – DummyBeginner Oct 28 '15 at 18:18
  • @BogdanWilli Symlink has worked great. But one thing: this way the flash plugin version number in front ofCHROMIUM_FLAGS in the /etc/chromium-browser/default would remain the old number and wouldn't change. So even though the file itself has been updated, but it presents a wrong version number to chromium (it can be seen in chrome://plugins). I don't know if this affects the functionality of the plugin. However, if you have a solution for this too, I'd appreciate it. – DummyBeginner Oct 30 '15 at 22:02
  • Also sudo apt-get remove adobe-flashplugin if you still have it installed because it will conflicts with pepperflashplugin-nonfree. – Maxime R. Jul 26 '16 at 20:35

Regarding version updates, you can add to /etc/chromium-browser/default the following line:

version=$(grep version /opt/google/chrome/PepperFlash/manifest.json | sed 's|.*"version": ||;s|"||g;s|,||')

and change the the pappi-flash-version flag linke accordingly:

CHROMIUM_FLAGS="--ppapi-flash-path=/opt/google/chrome/PepperFlash/ --ppapi-flash-version=$version"

And put the actual path to the files, wherever they are without having google chrome as well. Theoretically you don't even need any symlinks, unless the internal program rejects non-standard locations for some crazy reason, which would even lead anyone to question why it's asking for a location that should be hardcoded to begin with.

However, while it seems to work through chrome://plugins, on actual pages I get "couldn't load plugin". I don't think it's caused by this method of setting up the variables, though. Unless there are indeed crazy reasons.

Funnily enough chrome's flash works on chrome and firefox... but not chromium...


Thanks your manual install fixed my problem. It shouldn't be too hard to script this.

I'm running Chromium Version 37.0.2062.120 on a Debian 7.1 fork.

I have a somewhat different problem. If I install pepperflash, apt-get removes chromium & chromium-browser:

The following packages will be REMOVED:
  chromium chromium-browser
The following NEW packages will be installed:
0 upgraded, 1 newly installed, 2 to remove

The opposite is also true, when installing chromium, apt-get will remove pepperflash if it's installed.

Here's what I did:

  1. install pepperflashplugin-nonfree. This installed flash version

  2. copy the /usr/lib/pepperflashplugin-nonfree dir for use later.

  3. install chromium and chromium-browser which removed pepperflashplugin-nonfree.

  4. copy libpepflashplayer.so & manifest.json from the backup in step 2 to /usr/lib/chromium/plugins (I don't have a /usr/lib/chromium-browser dir).

  5. edit /etc/chromium/default and append --ppapi-flash-path=/usr/lib/chromium/plugins/libpepflashplayer.so --ppapi-flash-version= to CHROMIUM_FLAGS (I don't have /etc/chromium-browser/default).

for example:

CHROMIUM_FLAGS="--password-store=detect --ppapi-flash-path=/usr/lib/chromium/plugins/libpepflashplayer.so --ppapi-flash-version="

Here is an update, I used the method as described by DummyBeginner on a version of FLASH 23,0,0,185.

However I got the Pepper Lib directly from Adobe https://get.adobe.com/flashplayer/?no_redirect

Downloaded the .tar.gz for my linux version, inside I found libpepflashplayer.so, copied that to the "plugins" directory of Chromium and updated the "default" file with the version I found in the manifesto.json.

Works like a charm on chromuim version 50.0.2661.102 and Ubuntu 14.04 (64-bit)

Your Answer

By clicking "Post Your Answer", you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.