0

I use ubuntu 14.04 and I have an Acer V3-571G laptop. I have an O2 Box 6431 modem which I have received from O2. My wifi connection works fine except when I restart ubuntu or laptop. Next time it does not connect again. I can see there is a lot going between kernel and the o2 box and I see deauthenticated in between. Here is dmesg output:

[34154.787149] wlan0: deauthenticated from 18:83:bf:a6:a2:fc (Reason: 3)
[34154.872908] cfg80211: Calling CRDA to update world regulatory domain
[34154.878624] cfg80211: World regulatory domain updated:
[34154.878628] cfg80211:   (start_freq - end_freq @ bandwidth), (max_antenna_gain, max_eirp)
[34154.878630] cfg80211:   (2402000 KHz - 2472000 KHz @ 40000 KHz), (300 mBi, 2000 mBm)
[34154.878632] cfg80211:   (2457000 KHz - 2482000 KHz @ 40000 KHz), (300 mBi, 2000 mBm)
[34154.878633] cfg80211:   (2474000 KHz - 2494000 KHz @ 20000 KHz), (300 mBi, 2000 mBm)
[34154.878634] cfg80211:   (5170000 KHz - 5250000 KHz @ 40000 KHz), (300 mBi, 2000 mBm)
[34154.878635] cfg80211:   (5735000 KHz - 5835000 KHz @ 40000 KHz), (300 mBi, 2000 mBm)
[34158.386846] wlan0: authenticate with 18:83:bf:a6:a2:fc
[34158.406281] wlan0: send auth to 18:83:bf:a6:a2:fc (try 1/3)
[34158.408269] wlan0: authenticated
[34158.409813] wlan0: associate with 18:83:bf:a6:a2:fc (try 1/3)
[34158.438048] wlan0: RX AssocResp from 18:83:bf:a6:a2:fc (capab=0x411 status=0 aid=2)
[34158.438127] wlan0: associated
[34158.438267] cfg80211: Calling CRDA for country: DE
[34158.442413] ath: EEPROM regdomain: 0x8114
[34158.442416] ath: EEPROM indicates we should expect a country code
[34158.442418] ath: doing EEPROM country->regdmn map search
[34158.442419] ath: country maps to regdmn code: 0x37
[34158.442421] ath: Country alpha2 being used: DE
[34158.442422] ath: Regpair used: 0x37
[34158.442424] ath: regdomain 0x8114 dynamically updated by country IE
[34158.442447] cfg80211: Regulatory domain changed to country: DE
[34158.442448] cfg80211:   (start_freq - end_freq @ bandwidth), (max_antenna_gain, max_eirp)
[34158.442450] cfg80211:   (2400000 KHz - 2483500 KHz @ 40000 KHz), (N/A, 2000 mBm)
[34158.442452] cfg80211:   (5150000 KHz - 5250000 KHz @ 40000 KHz), (N/A, 2000 mBm)
[34158.442453] cfg80211:   (5250000 KHz - 5350000 KHz @ 40000 KHz), (N/A, 2000 mBm)
[34158.442455] cfg80211:   (5470000 KHz - 5725000 KHz @ 40000 KHz), (N/A, 2698 mBm)
[34158.442457] cfg80211:   (57240000 KHz - 65880000 KHz @ 2160000 KHz), (N/A, 4000 mBm)

There are a number of other devices in our home network and they all work fine. Every time that this failure happens, no matter if I restart my laptop or delete wifi connection and reconnect it, it won't connect untill I restart the modem itself.

What is this problem about and how can I solve it?

P.S. Here is iwconfig output:

wlan0     IEEE 802.11abgn  ESSID:"o2-WLAN84"  
          Mode:Managed  Frequency:2.412 GHz  Access Point: 18:83:BF:A6:A2:FC   
          Bit Rate=115.6 Mb/s   Tx-Power=16 dBm   
          Retry  long limit:7   RTS thr:off   Fragment thr:off
          Power Management:off
          Link Quality=60/70  Signal level=-50 dBm  
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:0  Invalid misc:127   Missed beacon:0

Update

With more search I have found a workaround from 2011, which says:

Killing wpa_supplicant seems to resolve the issue for some people

Even though its tool old I will try it and update the question.

  • If I am understanding, your saying you connect to wireless from your laptop that uses 14.04. Everything works fine until you restart the laptop. Then you try to connect again and it won't. Is this just the laptop or all devices? I'm inclined to think it on their end. – geoffmcc Jan 26 '15 at 22:01
  • @geoffmcc only the laptop, actually I have the only linux box here. BTW I searched for deauthenticated reason = 3 and I found some related information via arch wikis which I will give it a try when problem happens again. – Mehdi Sadeghi Jan 26 '15 at 22:06
  • I assume your referring to sudo killall wpa_supplicant Looks like a pretty old problem. Would think be fixed by now. I'm curious, let me know if that does it for you please. – geoffmcc Jan 26 '15 at 22:12
  • @geoffmcc unfortunately it had no effect. Still I have to restart the modem after every suspend-to-ram or restart. – Mehdi Sadeghi Jan 28 '15 at 21:29
1

Not your exact setup (laptop brand/modem) but a lot of the logs seem to match yours. Same issue, deauthenticating, reason 3

This is the post.

The solution for this person was

 sudo apt-get update && sudo apt-get install wicd

Then restart.

Like I said, different equipment, but simular logs. Might want to read through them first before you try my answer to be sure I'm not missing something.

But it solved this persons problems.

  • It did not solve the problem directly but it gives me more control over wireless setup, right now after playing with its configuration it seems that it wins the authentication battle. – Mehdi Sadeghi Jan 29 '15 at 8:48
  • Glad you got it working. I'm sure it was very frustrating. Sorry took 3 days. – geoffmcc Jan 29 '15 at 14:52
  • I had the same problem again, but after disabling wifi n protocol in my wifi access point it is working more reliably. – Mehdi Sadeghi Feb 1 '15 at 15:21
  • Hmm. That's odd. It a shame to have to disable N (if your card supports) as you get longer range and better mbps connection. – geoffmcc Feb 1 '15 at 15:31

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.