3

I just bought myself a new laptop, the MSI GS60 2QD Ghost. It comes with Windows 8.1 pre installed and the new UEFI software instead of the old BIOS. I've read a lot of threads about how to set up dual boot in a system like this but since I've read that Ubuntu now supports UEFI and Secure Boot I'm leaving both enabled to install 14.10. There are two things I'm not too sure about yet though.

  • While installing Ubuntu alongside Windows 8.1, where should I install the bootloader? I've read guides saying you need to install it where Window's bootloader is, other saying you need to install it in the MBR and others saying you have to create a /boot partition for Ubuntu and install it there. Help!.
  • I just booted into a Live sessions and I couldn't connect to the WiFi network; only the wired networks were being displayed. I tried googling around for the WiFi drivers but couldn't find any, any idea where I can find them? I don't have an Ethernet cable available now so I can't really install it as is then update through Ubuntu itself.

Adding more info:

Output for lspci -nnk | grep -iA2 net

04:00.0 Ethernet controller [0200]: Qualcomm Atheros Killer E220x Gigabit Ethernet Controller [1969:e091] (rev 13)
    Subsystem: Micro-Star International Co., Ltd. [MSI] Device [1462:1102]
    Kernel driver in use: alx
05:00.0 Network controller [0280]: Qualcomm Atheros Device [168c:003e] (rev 20)
    Subsystem: Bigfoot Networks, Inc. Device [1a56:1525]
  • If it has an Atheros N1525 killer wifi, you may be waiting for a while but open terminal and enter lspci -nnk | grep -iA2 net and add the result to your question – Jeremy31 Jan 26 '15 at 21:44
  • @Jeremy31 Added the output you requested but yeah, it seems to be the model you mentioned, are there no working drivers for it? – Laucien Jan 26 '15 at 22:10
  • bugs.launchpad.net/ubuntu/+source/linux/+bug/1389716 Not yet and there is no ETA on when or if it will be supported, you might want to look at the card to see what connector is there and find an Intel 7260 to use – Jeremy31 Jan 26 '15 at 22:51
  • Man that's a shame. Is there no work around either? I've been googling a bit but since I don't have an ethernet cable here (I'm on vacation and just bought the laptop) I can't try any of that out. – Laucien Jan 27 '15 at 0:42
  • 1
    possible duplicate of Ubuntu 14.04 Wireless not working: no network interface – Pilot6 Aug 14 '15 at 16:25
0

As Jeremy31 said the WiFi card isn't working (hopefully will get support in the short term) and to answer my other question I installed the bootloader in the same partition that had Window's bootloader (the ~300MB UEFI one) and everything worked perfectly. Didn't have to disable secure boot or anything at all and I can boot both OSs.

Thanks!.

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.