I was trying to get IEC958/SPDIF optical out working on my ASUS P8P67PRO V3 motherboard running Natty and I seem to have wiped out a crucial part of my sound setup.

Here is the output from some relevant commands (I hope):

sudo aplay -l  
aplay: device_list:240: no soundcards found...

ls /cat/asound*
ls: cannot access /proc/asoun*: No such file or directory

lspci -v
00:1b.0 Audio device: Intel Corporation 6 Series Chipset Family High Definition Audio Controller (rev 05)
Subsystem: ASUSTeK Computer Inc. Device 8469
Flags: bus master, fast devsel, latency 0, IRQ 22
Memory at fe720000 (64-bit, non-prefetchable) [size=16K]
Capabilities: <access denied>
Kernel driver in use: oss_hdaudio
Kernel modules: snd-hda-intel

pactl stat
Currently in use: 1 blocks containing 63.9 KiB bytes total.
Allocated during whole lifetime: 41 blocks containing 1.8 MiB bytes total.
Sample cache size: 0 B
Server Name: pulseaudio
Server Version: 0.9.22-24-g67d18
Default Sample Specification: s16le 2ch 44100Hz
Default Channel Map: front-left,front-right
Default Sink: auto_null
Default Source: auto_null.monitor
Cookie: bed7e0b0

Any advice greatly appreciated.

  • are you using that standard natty kernel or a later version?
    – fossfreedom
    Aug 19, 2011 at 17:49
  • @fossfreedom - uname -r : 2.6.38-10-server Aug 19, 2011 at 23:27
  • Are you still experiencing this issue?
    – jrg
    Feb 27, 2012 at 23:31
  • I ended up ripping out everything audio related and re-installing. not pleasant... Feb 28, 2012 at 11:25

9 Answers 9


I had the same problem. I solved it by running the following command

sudo modprobe snd-hda-intel

Inside a terminal window (Ctrl+Alt+T to open one).

  • 3
    Didn't work for me. Did absolutely nothing. Sep 17, 2014 at 15:54
  • It works for me under Debian 9 but I have to type it every time I restart the computer. Do you know why? Jun 2, 2018 at 13:36
  • It works. I have tried lot of other commands of loading pulse, alsa etc nothing worked. But this worked. Thanks Oct 14, 2018 at 21:58
  • 2
    In my Ubuntu 18.04, this was sudo modprobe snd_hda_intel as the output of lspci -v | grep snd suggested. And yes, it helped immediately. Thank you! Aug 8, 2019 at 3:08

Basic Troubleshooting Steps

  1. Is your volume turned all the way down, or is your speaker muted?

    Run the following command in terminal:

    $ pacmd
    Welcome to PulseAudio! Use "help" for usage information.
    >>> list-sinks
  2. Can you play a sound that is known to always play correctly?

    Run the following command in terminal:

    aplay /usr/share/sounds/alsa/Front_Center.wav

    If you are not a root user then:

    sudo aplay /usr/share/sounds/alsa/Front_Center.wav
  3. Can another user play one of these "known-good" sounds?

    Log in with another user account. If there are no others, you should create one with default settings.

  4. Is the system recognizing your sound card?

    Run the command in the terminal:

    sudo aplay -l

    The output of that command should look something like this:

    **** List of PLAYBACK Hardware Devices ****
    card 0: Intel [HDA Intel], device 0: ALC861VD Analog [ALC861VD Analog]
      Subdevices: 0/1
      Subdevice #0: subdevice #0

    If you see this:

    aplay: device_list:221: no soundcard found...

    that means that Ubuntu is not recognizing your sound card. Check that you have the proper modules installed.

    Then in terminal run the following command:

    sudo modprobe snd-hda-intel

    Now run the command:

    sudo aplay -l

    and see whether you are getting the list of hardware devices.

  5. Do you have the sound modules installed?

    Open a terminal and type (note the backticks ` for command substitution):

    find /lib/modules/`uname -r` | grep snd

    You should see a large list of items come up. If you don't, it means that the install process did not install the sound modules for you. To fix this, type in the terminal window:

    sudo apt-get install linux-restricted-modules-`uname -r` linux-generic

    After installing the modules, you will need to reboot for the changes to take effect.

  6. Is the sound card physically installed and recognized by your hardware?

    Open a terminal and type:

    lspci -v | grep -A7 -i "audio"

    This should output some information about your audio hardware. An example is below:

    00:1b.0 Audio device: Intel Corporation 82801G (ICH7 Family) High Definition Audio Controller (rev 02)
            Subsystem: Toshiba America Info Systems Device ff01
            Flags: bus master, fast devsel, latency 0, IRQ 22
            Memory at dc440000 (64-bit, non-prefetchable) [size=16K]
            Capabilities: <access denied>
            Kernel driver in use: HDA Intel
            Kernel modules: snd-hda-intel

This should resolve the sound issue in Ubuntu.


In case it helps anyone, I had a similar problem: Alsa was finding my USB soundcard, but Pulseaudio was not.

Turns out that if I changed my user to root (sudo su root), then Pulseaudio worked fine. So the solution was giving the correct 'audio' permission to my user:

sudo adduser myuser audio

All the above steps didn't solve the issue for me on Zesty 17.04, unfortunately. But I could activate the soundcard with:

sudo modprobe snd-hda-intel

That was already a good starting point.

Thus I could fix it that way:

  1. Create a file called soundcardfix in /etc/init.d.

  2. Fill the file with these two lines of code:

    /sbin/modprobe snd-hda-intel
  3. Enter this command in a terminal:

    sudo chmod +x /etc/init.d/soundcardfix
  4. Finally create symbolic links with these two commands in a terminal:

    sudo ln -s /etc/init.d/soundcardfix /etc/rc3.d/S02soundcardfix
    sudo ln -s /etc/init.d/soundcardfix /etc/rc5.d/S02soundcardfix

I hope it will help somehow. :)

  • 1
    This worked for me. sudo modprobe snd-hda-intel did it but I had to type it every time, and your instructions made it so that this is done at startup automatically. Now aplay -l gives me "Generic Analog" and "Generic Digital" device names instead of "Intel ALC887-VD Analog", etc, but I don't suppose that changes much? I have sound now, thanks!
    – jrsala
    Jan 19, 2018 at 21:40

Upgraded from 12.04 to 12.10 with the dist upgrade tool. First there was no grub and repaired that with rescatux. Then there was no soundcard found. I have looked through page after page and tried many of the solutions, about three hours of work when the solution was so simple that I'm surprised it's not the number one search result for this problem. Here it is:

Install the header and image files for your kernel.

sudo apt-get install linux-headers-3.5.0-26-generic linux-image-3.5.0-26-generic

I hope this works for you too!


My issue ended up being that secure boot had been enabled. I have a UEFI system with enabled Secure Boot. The EFI_SECURE_BOOT_SIG_ENFORCE kernel config prevents linux from loading unsigned third party modules if UEFI Secure Boot is enabled.

I disable Secure Boot in BIOS and it restored sound functionality.


For me, adding snd_hda_intel.dmic_detect=0 to grub boot options helped


This askubuntu question actually solved my problem, a simple one line change to the grub file

sudo gedit /etc/default/grub

Changing this line:



GRUB_CMDLINE_LINUX_DEFAULT="quiet splash snd_hda_intel.dmic_detect=0"


sudo update-grub

and Reboot. Voila! Fixed it.

Sound card not detected - Ubuntu 20.04 - sof-audio-pci


TL;DR: On a Dell XPS laptop, it may be a BIOS thing.

I've had the same - all of a sudden, Ubuntu stopped playing sound and no player could recognize the sound card, no soundcards found... from aplay -l, although all drivers were installed.

This happened on a Dell XPS 15 9560 with Ubuntu 16.04 dual booted with Windows 10.

After trying every troubleshooting step, including re-installing and booting into different kernels, I realized sound stopped working in Windows, too.

Eventually, it was something in the BIOS that suddenly gone haywire... After a BIOS update, the problem was solved.

On another occasion, when the problem repeated, I entered the BIOS, disabled Audio completely, applied, then re-enabled it, and on reboot, sound was back.

My takeaways:

  • If running a dual-booted system, and basic troubleshooting steps are not working, check whether sound is working on the other installed OS, too.
  • Make sure BIOS is up to date, and try to disable/enable Audio for getting the sound back.
  • Arg, I must have misclicked on the down vote, I don't even have a Dell XPS laptop... Sorry, I can't unvote now.
    – hsandt
    Dec 5, 2020 at 12:27
  • @hsandt no worries :-)
    – valiano
    Dec 5, 2020 at 19:13

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .