6

https://dl.dropboxusercontent.com/u/2188345/fonts.png

As you can see, Nautilus font has suddenly stopped respecting the OS defaults. It happened by random after a boot today. Resetting fonts to default does not help.

Any ideas what's happening?

Edit: Link to full image https://dl.dropboxusercontent.com/u/2188345/fonts.png

1
  • Did you recently install MS Corefonts? (ttf-mscorefonts-installer package) My system is doing this tonight, and I installed the fonts earlier. Jan 29, 2015 at 7:05

2 Answers 2

13

This happened to me after installing the ttf-mscorefonts-installer package. I tinkered a bit and now Nautilus looks right again (it's back to using the Ubuntu font, as it normally does in Ubuntu).

Here is my procedure:

1) I opened a terminal and executed this fontconfig command:

$ fc-cache -rv

2) After the command finished, I logged out and logged back in.

I found other helpful font information in these questions:

Firefox fonts changed after install ttf-mscorefonts (This is what convinced me there may be problems installing the ttf-mscorefonts-installer package.)

Can I override fonts installed by ttf-mscorefonts-installer, prefer Liberation fonts? (This is where I got the idea of trying a fontconfig command.)

UPDATE: As I mentioned in the comment below, I decided the ttf-mscorefonts-installer causes problems in recent versions of Ubuntu, so I removed it. Nowadays LibreOffice includes the Liberation fonts, which are metrically-compatible with three of the common fonts:

  • Liberation Serif: same metrics as Times New Roman
  • Liberation Sans: same metrics as Arial
  • Liberation Mono: same metrics as Courier

If you don't use LibreOffice, you can get the fonts above by installing fonts-liberation package.

You can also match some other common Microsoft fonts:

  • Carlito: same metrics as Calibri
  • Caladea: same metrics as Cambria

The two fonts above are available by installing the fonts-crosextra-carlito and fonts-crosextra-caladea packages.

If you need a font compatible with Impact, Verdana, Trebuchet or Webdings, unfortunately I don't have a suggestion at this time.

3
  • After lots of back-and-forth upgrading and downgrading various things on a new system, I have decided the ttf-mscorefonts-installer causes all sorts of odd problems and most folks probably don't want to bother with it. I used to consider it almost essential for dealing with cross-platform font issues. For LibreOffice, the Liberation fonts are metrically-compatible with Times New Roman (Liberation Serif), Arial (Liberation Sans), and Courier (Liberation Mono), and the Carlito and Caladea fonts (both now provided with LO) are metrically-compatible with Calibri and Cambria respectively. Feb 16, 2015 at 4:23
  • Update 6/2015: I found a site which describes some more open-source font "equivalents," however its focus is on fonts that resemble Windows fonts and they may not be metrically equivalent. (In other words, line-breaks and other text shapes will differ.) Jun 5, 2015 at 16:50
  • Have you tried askubuntu.com/a/546404/16395 ? Fonts f****up happens sometime to me too, and deleting that file is normally the solution...
    – Rmano
    Nov 14, 2015 at 19:16
1

I have faced the same problem when replaced my HDD with SSD. Fonts started looking just like in your pictures! I solved this by disabling the Ubuntu user auto-login in a system. When I switch my laptop, I have to enter password to see desktop but fonts and themes are now looking correct.

2
  • 1
    It could be that disabling auto-login also somehow triggered a refresh of your font caches. Did you try the fontconfig (fc-cache -rv) command mentioned above? Nov 15, 2015 at 20:09
  • 1
    Yes, I did. It didn't help. Nov 17, 2015 at 4:16

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .