0

I use GNOME Flashback (Metacity) in my Ubuntu 14.04 LTS installation because of performance (it's running in VirtualBox). In this mode, the menu bar of an application is usually placed below its title bar. Recently I downloaded Qt Creator (version 3.0.1-0ubuntu4) and it shows no menu bar in my GUI.

When I switch to Unity (called Ubuntu (default) in the chooser), the Qt Creator's menu is displayed correctly when I hover the mouse cursor over the top bar.

Is there any way to show AppMenu in GNOME Flashback? What should I do to use Qt Creator correctly with GNOME Flashback?

0

This is known problem in GNOME Flashback. From terminal:

gsettings set org.gnome.settings-daemon.plugins.xsettings overrides
'{"Gtk/ShellShowsAppMenu":<0>}'
0

The problem was caused by the Qt Creator 3.0.1 package. I upgraded it to 3.1.1 (using the package repository of Utopic, following https://help.ubuntu.com/community/PinningHowto#Recommended_alternative_to_pinning) and the menu is showing correctly now.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.