18

I am new to Ubuntu and I have problems with my Ubuntu 14.04. I plugged my wifi adapter but it did not work so I guess I need to install the driver manually but I don't know how to do it. I currently don't have an internet connection in that PC since the wifi adapter does not work and I cannot connect through ethernet cable.

These are the things I've tried so far (still did not work):

  • Installing the ath9k driver from a tar.gz. I followed this
  • Following this for installing the rt2800usb. I had errors on sudo modprobe -v rt2800usb saying "error could not insert rt2800usb invalid argument"

I appreciate your suggestions

EDIT: Here is what my wifi adapter looks like for reference.

EDIT2: Output of lsusb

  • Please edit you question to add the result of this terminal command: lsusb Welcome to askubuntu! – chili555 Jan 26 '15 at 12:20
  • @chili555 thanks for the response, I added a link to the output of lsusb. I need 10 reputation to be able to put pictures and more than 2 links so sorry for the first EDIT have to remove the link – krato Jan 26 '15 at 13:22
  • possible duplicate of how to install drivers for wifi adpator on ubuntu? – chili555 Jan 26 '15 at 13:23
  • Please note the usb.id is the exact same as the duplicate. – chili555 Jan 26 '15 at 13:23
  • It still requires an internet connection. Do you have an idea how to do it without? – krato Jan 26 '15 at 13:28
30
+250

Here is how you install it in about five minutes.

Krato: "Hey, friend, can I borrow your ethernet connection for just a few minutes? I brought along six of your favorite beverage."

Friend: "Sure, Krato, glad to help you! Let me put a couple of those beverages on ice."

You then open a terminal and do:

sudo apt-get install linux-headers-generic build-essential git
git clone https://github.com/porjo/mt7601.git 
cd mt7601/src
make
sudo make install
sudo mkdir -p /etc/Wireless/RT2870STA/
sudo cp RT2870STA.dat /etc/Wireless/RT2870STA/
sudo modprobe mt7601Usta

Your wireless should now be working. Detach the ethernet, thank the friend and enjoy!

Here is how to do it in about five days...maybe.

Go here: http://packages.ubuntu.com/

Select Trusty in the drop-down box. Search for linux-headers-generic and build-essential. Be sure to locate their dependencies and the dependencies of the dependencies. Be sure to download the correct version, either 32- or 64-bit. Once you've download about fifteen or so packages on another computer, transfer them with a USB stick or similar to the desktop of your Ubuntu computer. Open a terminal and install them:

cd ~/Desktop
sudo dpkg -i *.deb

It may complain that a package is missing a dependency. If so, download that and add it to the desktop and try again.

Write many posts on the forum to tell old Chili how you're stuck. Rinse and repeat.

Once that's all done, get this: https://github.com/porjo/mt7601/archive/master.zip Download it and then transfer it to your desktop, too. Right-click it and select 'Extract Here.' Now, back to the terminal.

cd ~/Desktop/mt7601/src
make
sudo make install
sudo mkdir -p /etc/Wireless/RT2870STA/
sudo cp RT2870STA.dat /etc/Wireless/RT2870STA/
sudo modprobe mt7601Usta

Your wireless should now be working.

In either event, when Update Manager installs a later kernel, known as linux-image, after the requested reboot, you must recompile:

cd ~/mt7601/src
make clean
make
sudo make install
sudo modprobe mt7601Usta

Please retain the files and these instructions for that time.

| improve this answer | |
  • 1
    Thanks man, you really know your thing! +1 for the "how to borrow tutorial", +1 for the options. I wanna try the 5 days but the dependencies might kill me. Gonna do the 5 minutes see if it works. – krato Jan 26 '15 at 14:03
  • it works now! ran ip link and there's ra0. lsmod also lists the driver. Would you know why this is still not part of the Linux kernel source tree? – krato Jan 28 '15 at 9:50
  • Inclusion in the kernel and then inclusion in an Ubuntu LTS version is a long process, I believe two years or more. Please see my edit above. Glad it's working! – chili555 Jan 28 '15 at 14:24
  • Excellent - confirmed this on TP-LINK TL-WN727N on Ubuntu 15.10. What's confusing is that there is already an "mt7601u" driver running, but it seems like that's not enough: what's needed is the "mt7601Usta" (as shown above). – AgentLiquid Nov 3 '15 at 6:51
  • @AgentLiquid Please start your own new question. I suspect it needs firmware. Let's find out. – chili555 Nov 3 '15 at 13:57

Not the answer you're looking for? Browse other questions tagged or ask your own question.