0

Just installed latest xampp package on my localhost and on my terminal everything looks fine as shown below:

root@SKYBUNTU:/home/maze# /opt/lampp/lampp start
Starting XAMPP for Linux 5.6.3-0...
XAMPP: Starting Apache...ok.
XAMPP: Starting MySQL...ok.
XAMPP: Starting ProFTPD...ok.

But when I tried to open phpmyadmin I get the following error:

Error

MySQL said: Documentation
#2002 - No such file or directory
The server is not responding (or the local server's socket is not correctly configured).
Connection for controluser as defined in your configuration failed.

I also looked at my status from the the XAMPP page on localhost and it shows that my MySQL database is deactivated.

Component   
Status  
Hint    
    MySQL database   DEACTIVATED        
    PHP  ACTIVATED      
    Perl     ACTIVATED      
    Common Gateway Interface (CGI)   ACTIVATED      
    Server Side Includes (SSI)   ACTIVATED      
    PHP extension »OPcache«  DEACTIVATED    see FAQ 
    PHP extension »OCI8/Oracle«  DEACTIVATED    see FAQ 

Can someone please tell/show how to fix this on Ubuntu 14.04 LTS. I desperately need this to be working.

0

They may are two problem: 1. MySql is off 2. your settings for your socket are wrong.

For 1. just restart the MySql server. For 2. grep -w mysql.default_socket /opt/lampp/etc/php.ini shows your socket. Try to set it to blank and run the server again.

| improve this answer | |
  • Thank you Denni for your answer. I tried the second option as the first option did not work, and I got thisfrom my terminal: mysql.default_socket= How do I blank it? I am a newbie. I tried to open up php.ini from the php folder but not sure if that is the one to edit. thanks. – moise andre Jan 26 '15 at 10:45
  • Correction: php.ini from /opt/lampp/etc/php.ini. I cannot save the file and getting access denied. Thanks you. – moise andre Jan 26 '15 at 11:50
  • Hi again, I managed to edit the php.ini file using gksudo gedit /opt/lampp/etc/php.ini and blanked :mysql.default_socket with a semi colon and saved it, but still getting the same old error. ubuntu is getting very frustrating for me at the moment. thinking of going back to windows again which is at least a straight forward installation. thanks. – moise andre Jan 26 '15 at 13:00

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.