by default the xorg.conf doesn't exist in /etc/

I could generate it by Xorg -configure. However in order to do this. I need to stop xserver. I can't do it at the moment.

So is it possible to get xorg's content or at least on option which is

Section "Device" (the driver line)

2 Answers 2


referring repeatedly to the assumption that it won't be necessary doesn't help those who have to. While the automatic startup does provide a functional Gui it is far from what the video card could really do.

xorg -configure on the other hand doesn't create a usable result, claiming that there are more devices than there really are (and so does the configuration look like)

For such issues it was extremely helpful to see, what the automate found and did when starting X as it is running now.


Usually you want need to set the xorg.conf file yourself since settings are automatically determined.

Most options can be guessed from the Xorg log at /var/log/Xorg.0.log (0 is the display number). If you've an i5 or i7 processor, you're likely using the intel driver (the log will have a line with "(II) intel: Driver for Intel Integrated Graphics Chipsets: ...").

If you still want to proceed generating the /etc/X11/xorg.conf file, you need to run Xorg -configure as root without an active X server. Disabling the X server will make you loose your graphical session, so make sure that you've saved all work and logged out. When ready, switch to a virtual console by pressing Ctrl + Alt + F1 and login the text console. First, stop the desktop manager: sudo stop gdm or if you're not using GNOME but KDE: sudo stop kdm. After that, you can run sudo Xorg -configure. After that, you can run sudo start gdm or sudo start kdm to get back to the graphical session. If not, (re)move the generated /etc/X11/xorg.conf file.

  • and there is no way to get current xorg.conf without xorg stoppage?
    – bakytn
    Aug 19, 2011 at 8:31
  • AFAIK not, I tried the one described at ubuntuforums.org/showpost.php?p=9322591&postcount=6, but it did not work for me.
    – Lekensteyn
    Aug 19, 2011 at 10:10
  • oh man it did work! "sudo X :2 -configure". But I see it's rather generic, I mean it doesn't contain any spefici to my current setup settings. But may be that's okay
    – bakytn
    Aug 19, 2011 at 10:48

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.