0

I've downloaded some gopro footage to my local hd and then copied the files from my hd to an external drive. Whenever I want to change the access rights it will switch back to read only in Nautilus. Likewise if I change the ones for the files below. How can I give full rights? I need to process the footage on a mac.

enter image description here

sudo parted -l /dev/sdb

Modell: JMicron Generic (scsi)
Festplatte  /dev/sdb:  500GB
Sektorgröße (logisch/physisch): 512B/512B
Partitionstabelle: msdos

Nummer  Anfang  Ende   Größe  Typ      Dateisystem  Flags
 1      1049kB  500GB  500GB  primary  ext2
  • Is the external drive mounted as read-only? Try to change the permission from the command line as the root user and check what happens. – heemayl Jan 25 '15 at 17:36
  • My user (nuc) can change and delete files, but only on this nuc. How? – empedokles Jan 25 '15 at 17:41
  • Does mount say anything useful? – heemayl Jan 25 '15 at 17:44
  • @heemayl : I've postet above what it says. – empedokles Jan 25 '15 at 17:50
  • Looks like it is mounted as FUSE FS. Check the solutions given here – heemayl Jan 25 '15 at 18:09
2

From this line
/dev/sdb1 on /media/nuc/500GB type fuseblk (rw,nosuid,nodev,allow_other,default_permissions,blksize=4096)
I see that external drive filesystem is NTFS and it was by default mounted without respect to NTFS permissions. In this case all files/directories will have the same permissions and attempts to change them will be ignored.

I have solved similar problem by making permanent share with explicit settings:
write line
UUID=C848-2413 /mnt/E_DRIVE vfat rw,user,exec,umask=002
into /etc/fstab where UUID is from sudo blkid. (Then mkdir /mnt/E_DRIVE, setting permissions, then umount / mount.)

Simpler alternative is to install special tool:
https://apps.ubuntu.com/cat/applications/quantal/ntfs-config/

  • The special tool somehow doesn't allow me to delete files via delete button. Is this normal? I could reformat it, if you can tell me a file format that both ubuntu and mac osx understands. – empedokles Jan 25 '15 at 18:57
  • You can reformat external HDD as FAT/FAT32/ext2f file system then copy again from linux HDD to it (I assume you have a copy of the files, please check before formatting.) From what I see in guides.macrumors.com/Drives_and_Filesystems they all are supported by macos x. – Vladimir Kovalchuk Jan 25 '15 at 19:02
  • I formated to ext2. But unfortunately I don't own the drive anymore (from what I see in nautilus). I deinstalled the suggested special tool, but it didn't change anything. – empedokles Jan 25 '15 at 19:48

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.