3

I have installed Ubuntu server 10.04.4 on VirtualBox but the screen appear too small. I read some guides that i have to change settings in grub to change the screen size, so i go to /etc/default/grub, opened grub in editor and edited this line #GRUB_GFXMODE=640x480 to GRUB_GFXMODE=1280x760. This is a resolution that my video card supports.

Then i updated grub and restarted the machine but it didn't work. When the machine starts loading in the beginning for a few seconds it goes into the screen resolution i have set but then goes back to the initial small screen resolution.

Any idea why it doesn't work?

0

Please elaborate are you talking about X11 server in the VM or about terminal fonts? In the former case you will need usual VBox Guest Extensions / DKMS, in the latter it heavily depends on text console management commands. I doubt that grub text console settings persist into login session, especially after this stuff with Plymouth et al.

| improve this answer | |
  • I am talking about terminal fonts (text mode). I have installed the guest extensions but if i am not wrong they are helpful only when you have GUI environment. – user1800997 Jan 25 '15 at 19:50
  • 1
    I have tried sudo dpkg-reconfigure -plow console-setup from unix.stackexchange.com/questions/49779/… allows selection of codepage (UTF-8) and keyboard, the font (Fixed) and (quite limited set of values for) font size (13 is min in my case). It re-builds initramfs so it will be applied at boot time. Also there is an option like "Keep resolution from boot loader", maybe this will persist your grub setting. BTW old answer askubuntu.com/questions/29328/… says 1280×1024 is OK, not 1280x768. – Vladimir Kovalchuk Jan 26 '15 at 13:53
  • I run the command and changed the font size from 14 to 16, 16 was the maximum, but this didn't change the font size nor the screen resolution. I also can't enter the command line on boot with pressing "c". I want to run vbinfo to see the supported resolutions but for some reason it doesn't allow me to enter the command line. – user1800997 Jan 27 '15 at 15:55
0

There is no need to run commands nor install guest additions. I just hit shift+ctrl+c so it takes the guest host to scale mode, and then you can adjust the scale factor from settings display and adjust it for larger.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.