I have built myself a small Ubuntu home server to store all my files, but one of my HDD has extremely low write speed (between 1 and 3 MB/s) and it's killing me because it's a 4TB drive and I have almost 2.5TB of data to put on it. Let me explain :

I bought my server with the following specs :

  • CPU : Intel Pentium G3440
  • MB : Asus H87M-E C2
  • RAM : Corsair 2 x 2GB DDR3

And with the following drives (one partition on each drive) :

  • SSD (sda) : Kingston HyperX 120GB SATA3
  • HDD (sdb) : WD Green 4TB SATA3
  • HDD (sdc) : Seagate ST4000 4TB SATA3
  • HDD (sdd) : WD Green 3TB SATA3

I installed Ubuntu 14.04 (with GNOME) on the SSD, and "salvaged" the Seagate 4TB drive from my Windows 7 x64 computer and it was full of data. It was partitionned in NTFS, and had Compression active (gained a couple of GB with this).

When I moved it to my server, I emptied it into the other drives (took me around 3 weeks, at an average speed of 2MB/s). I thought the low read speed was due to the fact that I was transferring from (compressed) NTFS to Ext4. Now that I have emptied the drive, and reformated it to Ext4 I assumed it would be much better, but when I tried to copy back some of the files, I saw that the average speed was still similar (around 2MB/s). So tried some other copies to test the speeds between the other drives, and all copies I try doing between the 3 large capacity drives (sdb, sdc, sdd) go slower than 2.7MB/s (sometimes as slow as 1MB/s).

Is there something I'm missing here ? Either Ubuntu configuration, partition settings, fstab parameters...

Please comment if you need me to post the result of some command. Here are the few I could think of (will edit if/when I have some new informations) :

/etc/fstab contents

/dev/sdb1 /media/tv         ext4    user,sync,auto,rw   0   0

/dev/sdc1 /media/tvarchive  ext4    user,sync,auto,rw   0   0

/dev/sdd1 /media/medias     ext4    user,sync,auto,rw   0   0

smartctl -H -i /dev/sdc

rgo@ATLAS:~$ sudo smartctl -H -i /dev/sdc
smartctl 6.2 2013-07-26 r3841 [i686-linux-3.13.0-44-generic] (local build)
Copyright (C) 2002-13, Bruce Allen, Christian Franke, www.smartmontools.org

Model Family:     Seagate Desktop HDD.15
Device Model:     ST4000DM000-1F2168
Serial Number:    Z300RC7R
LU WWN Device Id: 5 000c50 0647493a8
Firmware Version: CC52
User Capacity:    4 000 787 030 016 bytes [4,00 TB]
Sector Sizes:     512 bytes logical, 4096 bytes physical
Rotation Rate:    5900 rpm
Device is:        In smartctl database [for details use: -P show]
ATA Version is:   ATA8-ACS T13/1699-D revision 4
SATA Version is:  SATA 3.1, 6.0 Gb/s (current: 6.0 Gb/s)
Local Time is:    Sun Jan 25 13:39:15 2015 CET
SMART support is: Available - device has SMART capability.
SMART support is: Enabled

SMART overall-health self-assessment test result: PASSED

hdparm -Tt

rgo@ATLAS:~$ sudo hdparm -Tt /dev/sdc
[sudo] password for rgo: 

 Timing cached reads:   16144 MB in  2.00 seconds = 8080.82 MB/sec
 Timing buffered disk reads: 446 MB in  3.00 seconds = 148.67 MB/sec

hdparm -v

rgo@ATLAS:~$ sudo hdparm -v /dev/sdc

 multcount     = 16 (on)
 IO_support    =  1 (32-bit)
 readonly      =  0 (off)
 readahead     = 256 (on)
 geometry      = 486401/255/63, sectors = 7814037168, start = 0

Excuse me if my question is stupid, but did you connect your HDDs to motherboard via SATA cables, not USB, right?
The next question is why you have 'sync' in /etc/fstab? I dont have one in mine. Please try without this.

  • Holy mother !!! Now we're talking !!! Yes the HDD are internals, and I don't know why the "sync" option. I was looking for a way to auto mount my disks on boot (UNIX beginner), and copied it from somewhere on the Internet. Now that it's removed, I'm reaching 70 MB/s copy speed !!!! Thank you so much !!! – 3rgo Jan 25 '15 at 22:22

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.