0

I wrote a small BTRFS GUI in Oracle Java 8. I want to package it but I don't know how to specify that the software needs Oracle Java 8 (JRE) under the Control file.

1

Officially (https://help.ubuntu.com/community/Java) you cannot. Oracle Java is not in Ubuntu repo anymore. Is there a feature in .deb packaging to require a package in custom repo? (I doubt.) Otherwise you may require oracle-java8-installer and oracle-java8-set-default (http://www.webupd8.org/2012/09/install-oracle-java-8-in-ubuntu-via-ppa.html) and write in the package info something like "please add such custom PPA for this excellent package, dont worry they are honest people, trust me". (Please excuse my sarcasm if it offends you.)

I really feel pity for such state of things; Java imho deserves more respect. OTOH why are you insisting on Oracle java? OpenJDK works good as well.

  • I know I want/like to use openjdk but I wrote a JavaFX app. And even know JavaFX is open soruce. It will only compile/run under Oracle jvm. – Dan Jan 25 '15 at 19:20

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.