16

My networking status is on which is shown in first figure Network But the Networking icon i.e. the wifi icon is missing. How do I bring it back?
Wierless Icon is missing

16

It could be very well possible that your nm-applet application has been killed or crashed.

Try running this command in a terminal:

nohup nm-applet &

if you don't want nohup.out file, you can use

nohup nm-applet > /dev/null &
1
  • This was the one that worked for me. I did not have an Internet connection and was disconnected from my router, so I could not use apt-get to reinstall the network manager. Thanks a lot!
    – rayryeng
    Jun 18 '21 at 18:03
10

Run this command from the terminal, just copy and paste for accuracy.

sudo apt-get install --reinstall network-manager network-manager-gnome

This should work if you uninstalled the icon by mistake.

2
  • 1
    YESS!!! I've tried sooo many 'fixes' and this one finally did the trick!! FYI I also needed to reboot after this. THANK YOU!
    – James
    Oct 2 '16 at 19:05
  • When I try the cmd, I get the below error. Can someone help in resolving please. The following packages have unmet dependencies: network-manager-gnome : Depends: libnm-gtk0 (= 0.9.8.8-0ubuntu4) but 0.9.8.8-0ubuntu4.5 is to be installed
    – spharish
    Oct 3 '21 at 8:49
2

this fixed it for me...

sudo apt-get install indicator-applet-complete

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.