0

My problem started after i rebooted my pc from the terminal , not doing any upgrades ,just a simple reboot , i saw some warning about low space on the home folder nothing else but i think it is unlikely that this is the problem . My computer booted just fine ,but when i type my login password it freezes and nothing happens . I can't acces tty shell with CTRL+ALT+F(1...6) ,when i do this sometimes it loads all that output and keeps bring me the login screen and freezes , i managed to get to a login in tty once put after i type my password it reloading the login screen . I have installed on this machine a fluxbox windows manager and i could login there , and list my files and did some commands i saw on related problem posts , don't know if it's stupid or not .. tried reinstall ubuntu-desktop , unity what . nothing works for me ..

  • How'd you do the "simple reboot" from the terminal? – Xen2050 Jan 25 '15 at 9:33
  • i've just typed the reboot command .. – l0cal Jan 25 '15 at 9:52
  • If you didn't use the --force option that should "arrange for the system to be brought down in a safe way"... maybe a filesystem got corrupted somehow anyway. Tried to fsck them? – Xen2050 Jan 25 '15 at 10:13
  • i would not like to take that step says it's possible to damage my file system for is being mounted ... i don't want to lose my data .. i can see my files from the fluxbox enviroment with the ls command , not see them on desktop .. could be something with the other enviroment (primary one ).. – l0cal Jan 25 '15 at 10:27
  • 1
    fsck should check & fix the filesystem. There is a way to have it do a check at next reboot, since running it on a mounted FS isn't good. Or run a live DVD/USB and fsck the unmounted partitions from there. Can use the -n option for most FS's (msdos, ext) to do a check only too. – Xen2050 Jan 25 '15 at 10:31
0

Could be that being out of space is causing all the problems... that's the first error you mention, so should be the first thing fixed.
or a filesystem (FS) problem...
or there's some error in the GUI desktop...

But running from a live USB/DVD is the first step, to:

  • Check the FS for errors - [Note: if your hard drive is failing, then it will probably get worse no matter what, a whole-partition backup with gddrescue may be required, then fix & backup from the copy]

    To do a read-only check (if you're really paranoid about losses, but you should already have several backups in that case).

    fsck -nv /dev/<device>
    

    But you're probably using an ext3/4 filesystem on / & /home, so fsck would use the e2fsck program, and these options would be useful:

    • -n Open the filesystem read-only, and assume an answer of 'no' to all questions.
    • -f Force checking even if the file system seems clean.
    • -p Automatically repair ("preen") the file system. This option will cause e2fsck to automatically fix any filesystem problems that can be safely fixed without human intervention.
    • -v Verbose mode.
  • Mount the partitions - as read-only (mount -o ro <partition> <mountpoint>) if you're concerned about them getting changed.

  • Back up your files - Copy wanted files to some other partition, delete unwanted ones, to solve the out of space problem and prevent catastrophic loss in case there is a problem in the future.
  • Remove/re-install packages from a chroot environment (but if you can boot into single-user mode with networking that might be easier.
  • Even re-install if you think the errors are too serious to overcome.
| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.